Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎03-18-2013
My Device: Blackberry Torch
My Carrier: 02

Tunnel Failed



Everytime I attempt to use Twitter it just says 'Tunnel failed', I've tried my best to fix it myself by googling it but everytime someones suggested I click a box or change a setting I find that the box is already clicked and the setting is as they recommend.


I can check twitter online via the browser, I am receiving/making calls, text messages are coming through etc.  I don't use BBM so I don't know if this is working or not.


I have full signal, it says gprs (usually it has it in capital letters, like GPRS).  It's starting to drive me mad now, please help !

Posts: 2,649
Registered: ‎04-01-2008
My Device: 9500, 8110, 8700, 8220, 9100, 9800, 9810, Z10

Re: Tunnel Failed

Hello Penny88


Welcome to the forums. 


This may be related to the APN settings on the device. Have a look at this article to see how to change the APN settings. You will need to contact your mobile network provider to get the correct settings for their network. 


How to set the APN settings on the BlackBerry smartphone


Hope this helps. Have a good day. 



Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

New Contributor
Posts: 2
Registered: ‎03-18-2013
My Device: Blackberry Torch
My Carrier: 02

Re: Tunnel Failed

Thank you for getting back to me.


I've tried that already.  I've spoken to 02 who suggest I send my phone away to be looked at. 


To be honest, I think my phones coming to the end of its' life.  It's due an upgrade in 20days, I've dropped it god knows how many times & have even dropped it in the bath (when it was full) and it's still going so I think it's only to be expected that it's starting to give up on me.


Again, thank you for you help though.