Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Member
Posts: 1
Registered: ‎07-28-2012
My Device: bold 9900
My Carrier: Me

Turining Wifi off causes phone to switches off

Hi All.

I'm having battery issues, it does not last for a whole day. i was told to make a few adjustment to my bb setup one of them was to turn off Wifi when im not using it.

now im not sure what i have done but everytime i switch off wifi the phone switches off within a 1min.

i cannot turn the phone back on unless i do a battery pull and connect the phone to charge.

has anyone had this issue before?

i have a BB Bold 9900 unbrand and unlocked, OS, currently using a T-mobile sim in it.
Posts: 2,795
Registered: ‎05-10-2010
My Device: BlackBerry Z10 smartphone

Re: Turining Wifi off causes phone to switches off

Hi shabz81,


Welcome to the BlackBerry Support Community.

To resolve the issue of your BlackBerry® Bold™ 9900 smartphone switching off when Wi-Fi is turned off, please try performing the steps in the applicable article that follows. 

If you are using a  Windows® cpmputer, please try: http://bbry.lv/GI9beY
If you are using a Mac, please try: http://bbry.lv/J0UN1U


Hope this helps.





Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

New Contributor
Posts: 4
Registered: ‎07-07-2012
My Device: 9860
My Carrier: Celcom

Re: Turining Wifi off causes phone to switches off

hey there,


i'm experiencing the same issue for monyhs already. I've tried changing my batteries didn't work, i've tried reinstall the OS several times..still didn't work. I'm using Torch 9860 and running on OS 7.1 Bundle 2061 (v7.1.0.714, platform To have wifi turn on all the time is draining my battery badly. I have to keep on charging when i have the chance, at work, in car etc. Please help to rectify this issue.What else can we do despite changing the device? It started to creats this issue when i upgraded the OS. When I first bought this device it was fine. looking forward for your valuable reply.