Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎12-10-2008
My Device: Not Specified

UIApp video control initialization problem

Hi,

I've been trying for a couple of days to get video working in a RIM UIApp on a Blackberry 8800 (4.2.1) but despite following every code snippet I've found to the letter I still seem to be having problems.

In particular, the call to VideoControl.initDisplayMode(...) is failing, claiming an IllegalArgumentException because the second argument should be 'null or a java.lang.String'.

I've tried calling this method in the following ways and I always get this error (in both the 4.2.1 8800 simulator and on the device):-

videoControl.initDisplayMode(VideoControl.USE_GUI_PRIMITIVE, "net.rim.device.api.ui.Field".toString());

videoControl.initDisplayMode(VideoControl.USE_GUI_PRIMITIVE, "net.rim.device.api.ui.Field");

videoControl.initDisplayMode(VideoControl.USE_GUI_PRIMITIVE, new String("net.rim.device.api.ui.Field"));

Is there a bug in the API, and how do I work around this?

Thanks in advance for any help you can give..

Chris J
New Developer
Posts: 6
Registered: ‎11-25-2008
My Device: Not Specified

Re: UIApp video control initialization problem

Did you ever figure out your problem? I am trying to play video with the 4.2 JDE and I am getting that the GUI_PRIMITIVE_TYPE is not supported.
Developer
Posts: 70
Registered: ‎01-02-2009
My Device: Not Specified

Re: UIApp video control initialization problem

Hi,

 

Displaying video in this way requires BlackBerry handheld software version 4.3.0 or higher.

 

Check this link

 

http://supportforums.blackberry.com/rim/board/message?board.id=java_dev&message.id=15528&query.id=58...

 

 

---------------------
Best Regards,
Kannabiran.
---------------------
Don't forget to mark your post as solved if you got answer. And give kudos.
New Developer
Posts: 5
Registered: ‎04-20-2009
My Device: Not Specified

Re: UIApp video control initialization problem

Then is there any way to play video/mp4 in a media application? Don't want to use browser, it's out of control.

Thank you