Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums on April 1st. BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

New Member
Posts: 1
Registered: ‎02-14-2012
My Device: Blackberry Torch 9810
My Carrier: Bell Mobility

Unable to Update Blackberry Desktop Software while Tethering Blackberry to Laptop

Hello everyone. For what it is worth, I thought I would provide feedback on my experience in upgrading the Blackberry Desktop software to


I use my Blackberry as my only device to provide broadband internet for my laptop. Thus one is tethering when one needs to upgrade the desktop software to the latest version. Everything appeared to be working fine. The software detected an update. Then I proceeded with the update. The file downloads and the software alerts me that I cannot perform an update while the software is running. I expected this would happen. It provides two options "Close Now" or "Close Later". I selected "Close Now". The desktop software closes as expected. Then the update proceeds to unzip the download file. Once the unzipping is complete, the program simply closes with no error messages. I thought this was odd. I tried again. The same problem. I am running Windows 7 x64. I tried a reboot. Still the same problem. The only solution I was able to use was go to the BlackBerry Apps & Software section and download the file directly and save on the hard drive. Once downloaded, I closed the tethered internet connection and then closed the BlackBerry Desktop Software. This time, the download unzipped and then proceeded through the installation process. Also as expected, once the install was complete, I was prompted to reboot my computer. The reboot worked properly and I was able to run the new BlackBerry Desktop Software without problems. Obviously the tethered BlackBerry connection is working as I am posting this.


In the end, I want RIM to succeed! I enjoy their software and hardware. I was a bit annoyed the update process did not go as smoothly as it should. For what it is worth, I hope RIM will take this feedback and make improvements. Please RIM never take the direct download process away as users like me may have to look elsewhere for their services. It is easy for everyone to complain that things do not always work as expected. However, I am willing to help out in providing feedback to improve things. I enjoy the community environment of BlackBerry and want to see it grow even more. Hopefully if anyone else runs into similar issues, this post will be useful.


Everyone have fun with their BlackBerries.

Lovin' my Blackberry Torch 9810