Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
MSS
New Contributor
Posts: 3
Registered: ‎08-14-2012
My Device: Bold 9900
My Carrier: Entel

Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

Hello


I have a Bold 9900, software 7.0

I have had problems with App World for several months. The App on my phone indicated that an upgrade is available, however when I went to upgrade I received the following message:

 

Error : Invalid manifest or application descriptor.
The "MIDLet-Name" attribute is missing.

After several failed attempts trying to download the upgrade I finally deleted App World from my phone to try to re-install it directly from the phone, but this gives me the above error message.

I have tried to update it using the appworld.blackberry.com site, but was unsuccessful. After deleting App World from my phone the appworld site no longer recognizes my device and tells me to "Please connect your device" when I click the 'My World' link.

When I try to download AppWorld from the Blackberry website, I receive this message:

"Downloads via a USB connection are not enabled for this product. Please visit our mobile download site using the browser on your BlackBerry® smartphone."

I've hard rebooted the device repeatedly, hoping that this would help, but it hasn't.

Any ideas?

 

Posts: 94,670
Likes: 24,430
Solutions: 6,357
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

On your 9900 go to Options > Device > Applications and make certain AppWorld is deleted from your device.

Then, Do a simple reboot on the BlackBerry in this manner: With the BlackBerry device POWERED ON, remove the battery for a minute, and then reinsert the battery to reboot.

Now, using your BlackBerry browser, go to www.blackberry.com/appworld and download

 

Let us know what happens.

>> NEW! 10% discount on BlackBerry devices from ShopBlackBerry.com, including PRIV


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
MSS
New Contributor
Posts: 3
Registered: ‎08-14-2012
My Device: Bold 9900
My Carrier: Entel

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

Thanks for your reply.

 

I did everything exactly as instructed. I had already deleted AppWorld, so it wasn't in Applications (I checked again, just to be sure.)

 

I went through steps to download AppWorld on the browser (language selection, etc), and it landed me on the URL: http://mobileapps.blackberry.com/devicesoftware/download/servlet

 

Here I received the error message:

 

Error:  Invalid manifest or application descriptor.

 

The "MIDlet-Name"attribute is missing.

 

Same as before...

 

(I should point out that I am in Chile, although I checked the worldwide availability of AppWorld and Chile was listed.) 

Posts: 94,670
Likes: 24,430
Solutions: 6,357
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

For one thing, if you are on a 9900 on OS 7.0, you should upgrade to OS 7.1

>> NEW! 10% discount on BlackBerry devices from ShopBlackBerry.com, including PRIV


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
MSS
New Contributor
Posts: 3
Registered: ‎08-14-2012
My Device: Bold 9900
My Carrier: Entel

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

I have tried to download 7.1, but it seems it is not available for my region (Chile).

 

I have checked on 'Software Updates' on the device, where it indicates"Your Blackberry is up to date" and doesn't offer any option to update. 

 

I have also checked on the Blackberry website, and it also tells me there are no updates available.

 

It tells me I have this version on my phone: 7.0 2395 (v. 7.0.0.579, platform 5.0.0.735). It seems that the version releases may be related to geographical location and Carrier (I have Entel PCS as my carrier.)

 

I re-installed the latest update of 7.0 that the website would allow me to do, then tried to download AppWorld, but no success. 





Highlighted
Posts: 94,670
Likes: 24,430
Solutions: 6,357
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

Device operating system releases are "released" by specific carriers once they have certified and trained their support techs, but still, you are able to load to any carrier's same model by following the instructions below.

See the link below for the download, and follow these simple installation instructions.

https://swdownloads.blackberry.com/Downloads/contactFormPreload.do?code=8B6A80C3CF2CBD5F967063618DC5...

Do a backup of your device first, using Desktop Manager > Backup. Close Desktop Manager upon completion.

1. Download the OS file to the PC then install it to the PC by running (double clicking) the file you downloaded.
2. Go to c:\program files\common files\research in motion\apploader and delete the file named "vendor.xml."
3. Plug in BB and double click on "Loader.exe." It's located in the same place as the above vendor.xml file.

Note: Some users might worry they will void their device warranty by loading an OS from another carrier. There is really nothing to worry about. Please read more information on that here: http://www.port3101.org/power-users/296-blackberry-os-upgrade-including-betas-myths-dispelled.html

>> NEW! 10% discount on BlackBerry devices from ShopBlackBerry.com, including PRIV


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Member
Posts: 1
Registered: ‎11-06-2013
My Device: 9810
My Carrier: Exclusive store

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

I am also getting the same error. The OS is already at version 7.1.0.536.

 

Please help me troubleshoot this issue.

 

Regards,

Mrunal

New Contributor
Posts: 2
Registered: ‎02-14-2015
My Device: BlackBerry passport
My Carrier: AT&T

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

[ Edited ]

The error has been fixed now.

 

Best regards.

 

 

Mod edited to remove external link

New Member
Posts: 1
Registered: ‎07-13-2015
My Device: torch 9800
My Carrier: orange

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

how did you fix this? i'm having the same problem with my 9800

New Contributor
Posts: 7
Registered: ‎10-07-2011
My Device: BB9700
My Carrier: Qtel

Re: Unable to download/upgrade App World - Error Invalid manifest or application descriptor.

So how was that fixed? I am geeting the same error now on my 9780