Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 7
Registered: ‎03-25-2013
My Device: 9810
My Carrier: telstra

Unable to install 9.1 on 9810

Help please.

 

Im unable to install OS 7.1 onto my 9810 phone. I have tried using Blackberry desktop also downloading file from internet also wireless and keep getting the same message that there are no updates for my phone. The phone currently has 7.0.0474

 

Hall of Famer III
Posts: 58,176
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Unable to install 9.1 on 9810

Hello,

The simplest way is to, on a PC (you cannot do this on MAC):

1) Uninstall, from your PC, any and all BB OS packages

2) Make sure you have the BB Desktop Software already installed

3) Download and install, to your PC, the BB OS package you desire:

4) If that OS package is from a carrier other than the carrier for which your BB was originally manufactured (if you are not sure, delete these anyway), then delete, on your PC, all copies of VENDOR.XML...there will be at least one, and perhaps 2, and they will be located in or similarly to (it changes based on your Windows version) these folders:

  • C:\Program Files (x86)\Common Files\Research In Motion\AppLoader
  • C:\Users\(your Windows UserName)\AppData\Roaming\Research In Motion\BlackBerry\Loader XML

5) Launch the Desktop Software and connect your BB...the software should offer you the OS package you installed to your PC. If, during the process, your BB presents a "507" error, simply unplug the USB cord from the BB and re-insert it...don't do anything else...this should allow the install to continue.

Don't forget to backup.


If you are on MAC, you are limited to only your carriers sanctioned OS packages...but can still use any levels that they currently sanction. See this procedure:

  • KB19915How to perform a clean reload of BlackBerry smartphone application software using BlackBerry Desktop Software

Good luck and let us know!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎03-25-2013
My Device: 9810
My Carrier: telstra

Re: Unable to install 9.1 on 9810

Thanks for your reply. Tried what you said and still get the same message that there are no updates. I was not able to find any vendor XML files however the laptop i installed the desktop program on had never had this before.

Anymore ideas?????

Hall of Famer III
Posts: 58,176
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Unable to install 9.1 on 9810

Given that result, you did not override the automatic method of the Desktop Software matching your device VendorID against what that specific carrier makes available on line. And, it therefore told you that you are already running the most up to date version...but that's based on the carrier that matches the VendorID, not the specific OS package that you downloaded.

If you do not delete the VENDOR.XML file(s), then the OS package you want to use will be totally ignored...resulting in exactly what happened. If you want to use that OS package, you quite simply MUST delete those VENDOR.XML file. If you do not, then you will be limited to only what your carrier (by matching the VendorID) supports, which means no option to update.

There is no other way. You simply must find and delete those VENDOR.XML files.

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎03-25-2013
My Device: 9810
My Carrier: telstra

Re: Unable to install 9.1 on 9810

I did also download the AT&T upgrade as this is what the BB is. Should that not of fixed the problem?

Hall of Famer III
Posts: 58,176
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Unable to install 9.1 on 9810

Only if you re-did all of the steps in post 2 above...having more than one BB OS package installed to the PC can cause the update process to be confused. Further, if your BB VendorID is not for ATT, then that package also would have been ignored unless the VENDOR.XML file(s) were deleted before trying to use it.

But, then again, since all you said is that you downloaded something, but did not reveal what you did next from that, I can't really know. Did that ATT OS install to your BB?

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎03-25-2013
My Device: 9810
My Carrier: telstra

Re: Unable to install 9.1 on 9810

The AT&T did not insatll to my BB I had the same message that there is no update. The laptop I used I had not previously linked the BB to it before. I downloaded the desktop software then downloaded the OS upgrade howevre I did it in telstra first then tried the AT&T upgrade.

I did look into the folders you suggested for the vendor file but could not find anything also did a search of the RIM folder with still no luck.

Hall of Famer III
Posts: 58,176
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Unable to install 9.1 on 9810

Sorry...I don't want to sound picky, but I need to be very exact. You say you "downloaded" the desktop software and "downloaded" the OS package. But, did you INSTALL them BOTH to your PC? You must download AND install both of them to your PC in order to actually use them. And the VENDOR.XML files MUST be deleted if you are using a BB OS package as described above. Those VENDOR.XML files might not come up in a search...you need to navigate (via Windows Explorer) to those locations as they are listed in the earlier post above...if you've installed the BB OS package to your PC, then those VENDOR.XML files will definitely be there...and unless you truly find and delete them, then the BB OS package you installed to your PC will quite simply be ignored, resulting in what you are reporting.

If you've tried multiple BB OS packages, then you need to be certain that you've uninstalled from the PC the ALL of the BB OS package that you don't want to use, leaving only one installed to your PC.

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎03-25-2013
My Device: 9810
My Carrier: telstra

Re: Unable to install 9.1 on 9810

Yes I did install the desktop and OS files to the PC. There didnt appear to be any problems there. I will need to find those files obviously.

 

Thanks

 

I will let you know.

Hall of Famer III
Posts: 58,176
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Unable to install 9.1 on 9810

Hi! Yup...I agree...you must find and delete those.

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................