Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
Visitor
Posts: 1
Registered: ‎10-10-2012
My Device: BlackBerry Curve 9300 3G
My Carrier: Unlocked

Unable to update my OS.

I have a BlackBerry Curve 3G with the 5.0 OS and i want to update my phone up to 6.0 and I can't.

 

Reasons why are 1 i can't do it with the desktop manager because it says i need an active BlackBerry subcription, and 2 I've tried the software download install and deleting the Vendor.xml file, and using the Loader file, and the OS just doesn't appear. I don't want to break my BlackBerry so I've stoped trying to sort it. 

 

So please could a BlackBerry advisor help me get an "Active BlackBerry Subscription" 

 

Sincerly, 

 

Wil

Retired
Posts: 2,283
Registered: ‎09-09-2010
My Device: BlackBerry Z10 Smartphone

Re: Unable to update my OS.

Hey Will,

Welcome to the BlackBerry® Support Community Forums.

 

Please have a look at the following article that provides information on being unable to upgrade the BlackBerry® Device Software and the error message you are receiving:

 

Unable to upgrade BlackBerry Device Software because the message "BlackBerry Device Software updates are only available to BlackBerry smartphone users with an active BlackBerry service subscription" appears when Desktop Manager is launched
http://btsc.webapps.blackberry.com/btsc/KB19921

 

 

Thanks.

 

 

-HB

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!