Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎06-30-2013
My Device: Curve 9320
My Carrier: Giffgaff

Unable to upgrade Blackberry Appworld

[ Edited ]

I have a Curve 9320 and when trying to use the BB Appworld I get a dialog requesting me to upgrade. The upgrade NEVER completes successfully - I always get a BB App Word get Midlet-Name error. I have tried application removal, resets, battery pulls and always get the same error which suggests something wrong server side with the delivery of the application. Any advice?

New Contributor
Posts: 4
Registered: ‎06-30-2013
My Device: Curve 9320
My Carrier: Giffgaff

Re: Unable to upgrade Blackberry Appworld

I've upgraded the OS to the most recent version (7.1 Bundle 2039) and restarted the device.

Again, the Appworld application refuses to let me use it insisting I upgrade. I then follow the instructions precisely to upgrade via the official Blackberry sites (either in the US and UK) and this always fails with the following error:

 

Error: Invalid manifest or application descriptor

The "MIDlet-Name" attribute is missing

 

 

New Contributor
Posts: 4
Registered: ‎06-30-2013
My Device: Curve 9320
My Carrier: Giffgaff

Re: Unable to upgrade Blackberry Appworld

I managed to resolve this by updating via the Appworld website and the Appworld web-browser plug in.

The device was updated from my PC with a USB cable.

The Appworld web-app noticed that my Curve was out of date and installed the application.