Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 1
Registered: ‎09-29-2010
My Device: Blackberry Tour 9630
My Carrier: Verizon

Unlocked 9630 from Verizon BIS problem

I had a 9630 that was unlocked by Verizon in January 2010. I had it unlocked so I could use my SIM Card for Vodacom in South Africa which had a blackberry contract, inclusive of Data. I was in South Africa from January to Mid-September.


The phone worked perfectly until May, upon which I had occasional cut-outs of BIS. By the end of May, I had suffered 2 weeks without internet. I filed many complaints with Vodacom, and the issue was even escalated to RIM. But I never had any progress. It worked for a day, sparatically. The issue continued until I left in Mid-September. Upon arriving back in the USA, my blackberry worked perfectly on my CDMA Verizon contract,but I am planning on returning to South Africa. I would like to know what this issue was, and how it can be fixed. Vodacom and Vodaworld (a Tech World for Vodacom) could not do much, as the phone was American and, though there are many people in South Africa with the same phone, all have suffered the same problem. We also upgraded to OS 5 and reverted to the previous OS 4 to try see if it would make a difference.


As a side note, I was able to use WAP browsing, which I had to pay for, but the BIS didn't work, no matter how many HRT or battery pull restarts I attempted.

New Member
Posts: 1
Registered: ‎05-18-2012
My Device: 9630
My Carrier: Vodacom

Re: Unlocked 9630 from Verizon BIS problem

Hi The only thing left to do is change ur network cos vodacom is no help at all, i had the same problem, contacted vodacom lyk 50 time with no help from ther side. Changed to mtn and problem solved within seconds. Vodacom sent out messages to say these phones r not supported by the networks cos of some cdma **bleep**. But my question is why did it apparantly work all this time and now all of a sudden its not supported