Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎12-02-2008
My Device: Not Specified

Upgrade to 4.6.0.190

I have a problem after I upgrade to v4.6.0.190 official, now I can't read SMS in Chinese Character. And Language support only have English (USA) and English (UK). Please help me. Tq
Regular Contributor
Posts: 63
Registered: ‎12-02-2008
My Device: Not Specified

Re: Upgrade to 4.6.0.190

[ Edited ]

make sure you have a multilanguage version of that OS. I believe AVEA the carrier in Turkey released a multi version of it. Also make sure you install Chinese pack too!

 

check it out

===================

Details
BlackBerry Handheld Software v4.6.0.331 (Multilanguage)

Package Version: 4.6.0.331
: 4.6.0.190

Software Platform: 4.0.0.172
File name: 9000M_PBr4.6.0_rel331_PL4.0.0.172_A4.6.0.190_AVEA. exe
File size: 93.55MB

https://www.blackberry.com/Downloads/entry.do?code=25DF35DE87AA441B88F22A6C2A830A17

Message Edited by pyrex on 12-03-2008 01:02 AM
Message Edited by pyrex on 12-03-2008 01:03 AM
Developer
Posts: 70
Registered: ‎09-17-2008
My Device: BlackBerry Bold 9000
My Carrier: Rogers

Re: Upgrade to 4.6.0.190

Unfortunately, the AVEA version of 4.6.0.190 does NOT include asian language support.

 

Instead, download the 4.6.0.190 (EastAsia) version, from the Singapore Telecom site:

https://www.blackberry.com/Downloads/entry.do?code=3DD48AB31D016FFCBF3314DF2B3CB9CE

 

Note - it is the SECOND option on the Blackberry 9000 page from Singapore. The first one is Multilanguage like AVEA. You need the second one (EastAsia), that looks like this:

 

BlackBerry Handheld Software v4.6.0.331 (EastAsia)

Package Version: 4.6.0.331
Consisting of:

  • Applications: 4.6.0.190
  • Software Platform: 4.0.0.172
  • File name: 9000jEastAsia_PBr4.6.0_rel331_PL4.0.0.172_A4.6.0.190_Singtel.exe
  • File size: 95.34MB
Note: The Software Platform and Applications version numbers can be found under Options-About screen on the handheld.



Cheers. FYI - just installed this version -and it's working brilliantly.

Contributor
Posts: 10
Registered: ‎11-28-2008
My Device: Passport
My Carrier: Airtel

Re: Upgrade to 4.6.0.190

 

 

 

Me too running on this new upgrade and all my problems have dissapeared for the past 10 days.I remember we could choose which language we needed somewhere during the installation and i am sure i saw Chinese somewhere.Rgds

"RULE EVERY ROAD YOU TAKE"
New Contributor
Posts: 5
Registered: ‎12-03-2008
My Device: Bold

Re: Upgrade to 4.6.0.190

I was gonna ask the same sort of question for the JP language pack. I saw the East Asian part with Japanese available in the vendor.xml before deleting, however didnt see where to grab it, so I just grabbed the generic US/UK English one.

 

Thanks for posting the link :->

SCCP or SIP clients for BB info. always wanted - Cheers
Regular Contributor
Posts: 86
Registered: ‎09-26-2008
My Device: Not Specified

Re: Upgrade to 4.6.0.190

My Bold is using version .168, when I tried to upgrade to version .190, it says there's no uprgade available. Same thing when I tried to upgrade to .185.

 

How do I upgrade to version .190?

Developer
Posts: 70
Registered: ‎09-17-2008
My Device: BlackBerry Bold 9000
My Carrier: Rogers

Re: Upgrade to 4.6.0.190

chulap - I actually wrote a guide a long while back. Here is a summarized version:

 

1) Head to the link to version 4.6.0.190.

2) Choose Blackberry Bold 9000 Software from the drop-down menu.

3) Click "Download this software" at the bottom of the page.

4) Answer the required information, then click next to begin downloading the software.

5) Make sure you do not have Desktop Manager open, OR your blackberry plugged in, then launch the software you just downloaded. Just go through the install process, it should be pretty straight forward.

***Head to c:\program files\common files\research in motion\apploader and delete the file vendor.xml****

6) Once the software has been installed, launch Blackberry Desktop Manager and connect your Bold via USB.

7) When Desktop Manager starts, it SHOULD detect new software then ask you to upgrade. If it does - click yes, and go ahead! It will take about 30 minutes.

8) If there is NO popup asking to upgrade, just click Application Loader, and that should trigger the software upgrade.

 

You were probably missing the step I bolded above.

 

The entire thread is here if you're interested:

http://supportforums.blackberry.com/rim/board/message?board.id=Bold&message.id=2120#M2120

Regular Contributor
Posts: 86
Registered: ‎09-26-2008
My Device: Not Specified

Re: Upgrade to 4.6.0.190

I followed exactly as your old guide which is slightly different from this one. In your old guide you said delete vendor.xml before step 5. But this one you said delete vendor.xml after step 5.

 

However, following this new guide, I'm still unable to upgrade to .190. My bold still shows version .168.

Highlighted
Regular Contributor
Posts: 86
Registered: ‎09-26-2008
My Device: Not Specified

Re: Upgrade to 4.6.0.190

All done. Got it upgraded to .190. The problem was with the desktop manager. I was using the latest version 4.7. I uninstalled it and re-installed 4.6 and the upgrade went smoothly.