Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
Contributor
Posts: 12
Registered: ‎06-23-2009
My Device: Not Specified
Accepted Solution

Upgrade to OS 5

Hi to all,

 

I have tried everyway possible to upgrade and no luck on my AT&T Bold 9000.

 

I have the latest desktop manager and device OS (v4.6) and still no luck.

The new updater requires the Microsoft .NET 4 client policy update which I have.  Still no luck...

 

What am I missing here?  Should be this hard to apply the OS 5!

 

I suspect as usual that it is AT&T's fault!

 

GAry

 

Posts: 94,247
Likes: 24,335
Solutions: 6,331
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Upgrade to OS 5

Do you have a BlackBerry Data Plan enabled on your account with your carrier or mobile provider?

See the link below, for the download and simple installation instructions.

http://www.blackberryforums.com/general-9000-series-discussion-bold/227070-latest-os-9000-5-0-0-1137...

 

Do a backup of your device first, using Desktop Manager > Backup. Close Desktop Manager upon completion.

1. Download the OS file to the PC then install it to the PC by running (double clicking) the file you downloaded.
2. Go to c:\program files\common files\research in motion\apploader and delete the file named "vendor.xml."
3. Plug in BB and double click on "Loader.exe." It's located in the same place as the above vendor.xml file.

>> NEW! 10% discount on BlackBerry devices from ShopBlackBerry.com, including PRIV


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 12
Registered: ‎06-23-2009
My Device: Not Specified

Re: Upgrade to OS 5

Yes - I have a data plan.

 

The process outlined worked thanks!

 

To bad a company like AT&T are so far behind the curve!

 

Only issue is I lost the icons to the Word, Sheet, Presentation To Go applications.

 

Besides that all is good - any ideas on the icon issue?

 

Gary

 

Posts: 94,247
Likes: 24,335
Solutions: 6,331
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Upgrade to OS 5

 


garypaquette wrote:

 

Only issue is I lost the icons to the Word, Sheet, Presentation To Go applications.

 

Besides that all is good - any ideas on the icon issue?

 


 

Go back to Desktop Manager and open Application Loader. See the list of applications loaded to your device? Make sure DocumentsToGo is checked to install.

 

Then, look in all folders on your device -- Applications, Downloads, etc., for the icons.

>> NEW! 10% discount on BlackBerry devices from ShopBlackBerry.com, including PRIV


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 12
Registered: ‎06-23-2009
My Device: Not Specified

Re: Upgrade to OS 5

Thanks - only way was to re-install the apps and that worked fine.

The OS 5 is much quicker than the previous v4.6

 

Now that I do not have the vendor.xml which maintains the version listing (for v5.0) what is the latest version of OS 5  (build number) for the US English?

 

Thanks!

 

Posts: 94,247
Likes: 24,335
Solutions: 6,331
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Upgrade to OS 5

[ Edited ]

 


garypaquette wrote:

Now that I do not have the vendor.xml which maintains the version listing (for v5.0)


Nope, the vendor.xml file basically tells the OS installation that you have an "ATT device, and to load this theme, not those other vendor themes, load this application or that application, disable BBMaps,", etc., and has nothing to do with the versioning of the OS.


garypaquette wrote:

what is the latest version of OS 5  (build number) for the US English?


The link I posted for you above (5.0.0.681) is the latest officially released OS -- by any carrier -- for the 9000 Bold.

 

>> NEW! 10% discount on BlackBerry devices from ShopBlackBerry.com, including PRIV


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 12
Registered: ‎06-23-2009
My Device: Not Specified

Re: Upgrade to OS 5

Thanks - any of the 681 updates for the US English vs. UK English.

I see I can download the 681 from the BB web site, is there any difference between the versions posted there example:  a CDMA vendor vs. GSM?  Since the 5.0.0.681 is available for other vendors in US Engilsh.

 

Thx!

Gary

New Contributor
Posts: 3
Registered: ‎07-06-2010
My Device: 9000 Bold
My Carrier: At&t

Re: Upgrade to OS 5

I also have the BB 9000 bold and I have been trying for days to update to the 5.0.   I ran accross this forum in a google search and it seems to have got me once step closer.   I downloaded the file posted inside the link (5.0.1.65)  I ran the loader after deleting the vender file

 

It says

 

Application Loader

 

the blackberry desktop software does not

blackberry software for the devise that

you have connected to the computer. Contact

your service provider or system administrator

 

 

On my BB, under "about" it show BB 9000, v 4.6, the box says it, inside the battery cover says it... so im sure its the bb bold 9000.  Inside the loader i can click on "add" but i dont know what to do from there.

 

I also am running vista.... i also have "desktop loader", "BB devise manager", " BB media sync" and "BB desktop redirector".  I D/L all these trying to update to v5.0 OS

Contributor
Posts: 12
Registered: ‎06-23-2009
My Device: Not Specified

Re: Upgrade to OS 5

Are you running the v5.01 Desktop Manager?

 

Also check once you install the download then delete the vendor.xml.

The run the apploader.exe from the same location you deleted the vendor.xml file from.

 

That should do it for you.

 

New Contributor
Posts: 3
Registered: ‎07-06-2010
My Device: 9000 Bold
My Carrier: At&t

Re: Upgrade to OS 5

I do have the 5.0 desktop, and yes I delete the vinder file and opened "loader" up while i still had the folder open.   It starts the load program and connects to the BB... does some 3 step thing. Then the window pops up about not having the correct devise attached.   In the desktop program..... I click on upgrade and it pulls up the newest version of the OS as v4.6.XXXX,  it also shows that i can change it to an older version