Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 15
Registered: ‎11-21-2012
My Device: Q10
My Carrier: Vodafone

Viber 2.4



I have been using Viber 2.3 and older versions without any problem. I tried to download the newest Viber 2.4 via BB World, but I have problem running it. I receive the following message:


uncaught exception: java.lang.NoClassDefFoundError


Than Viber is installed, seems that everything is ok, than asks for permissions for connections etc, but I cannot move forward, it does not start.


My phone:

Bold 9700

Hungarian language


Do you have any solutions? I tried batter pull off, downloading older OS, nothing worked.



Trusted Contributor
Posts: 108
Registered: ‎12-05-2011
My Device: 9900
My Carrier: o

Re: Viber 2.4


Hi there ,

This is a member of the Viber Team. Smiley Happy


Did you try to uninstall>reinstall Viber?

Do you use WiFi or 3G?

An official representative from Viber Media (Viber app.)