Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎12-19-2011
My Device: Syle 9670
My Carrier: Sprint

Why are so many Apps for Blackberry only Available for Specific Blackberry Models, instead of by BB O.S. Version?

Please forgive me if this isn't the right forum, I am first time poster...  Can anyone tell my why Apps for Blackberry are available by specific model Blackberry, instead of by BB O.S. version?  I noticed that with Apps for Android and iPhone, App availability is generally based on what version of O.S. is being run.  Granted there are a myriad number of Blackberry models out there, but with BB O.S. versions in recent years numbering just from 4-7, you would think the specific BB model number should be irrelevant and the BB O.S. version would control/determine app availability.

 

Can you tell I am frustrated BB Style 9670 user who has discovered that the mobil app for such large organizations as Delta Airlines, PriorityPass, WeatherBug, and AccuWeather (to name just those I found today), are all not available for the 9670 (yet these have long lists of other BB O.S. 6 phones supported)?

 

Thanks for any help you can provide!

New Member
Posts: 258
Registered: ‎06-01-2011
My Device: PlayBook, Z10
My Carrier: Telus Mobility

Re: Why are so many Apps for Blackberry only Available for Specific Blackberry Models, instead of by BB O.S. Version?

I too would like to know this. The Air Miles app is available for most models, but not the Style.

 

Shane.

Hall of Famer III
Posts: 57,243
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAF518), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Why are so many Apps for Blackberry only Available for Specific Blackberry Models, instead of by BB O.S. Version?

The answer is actually simple...example...6.0.0.415 for a 9860 is very different from 6.0.0.415 for a 9670. Hence, the app developers must port their apps to every combination of (usually) major OS level (e.g., 6.0, 7.0, 7.1) and specific device model number. That's a lot of combinations to which they must port their app...and many choose to not do them all. But the choice is the app developers.

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................