Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Visitor
Posts: 1
Registered: ‎06-12-2010
My Device: Curve 8520
My Carrier: T-Mobile

WiFi and Uma Troubles

Three days ago I recieved my two new Blackberry Curve 8520's. I am new to using Blackberry. T-Mobile is the provider. I ordered these phones because I do not get T-Mobile signal inside my house and was assured that these phones can use WiFi and UMA for data and voice calls via my  home wireless router.

 

I am beginning to be very sorry I ordered these phones and it's leaving a very bad taste in my mouth. They have been basically unuseable since they arrived. I have called T-Mobile tech support and everything is set up as it should be on their end. My phones are configured as they should be.We have gone through many troubleshooting steps and nothing corrects the problem. Pulling the battery helps for about 10 minutes then the problem persists.

 

I can connect to my wireless network and it hold the "signal" for 5-10 minutes at a time. I can make a call, surf the web just fine. Then I lose the signal and the "SOS" is displayed instead of "UMA". Although the little WiFi icon is still there, I lose data as well.

 

I have rebooted and reconfigured my router several times. My  Android device has no problems using the WiFi. It is flawless and stays connected for as long as I leave the connection turned on. My computers use the wireless router flawlessy as well. It's definitely the phones.

 

I am at the end of my rope here and am willing to try anything, so if anyone has any ideas, I am all ears.

Highlighted
Contributor
Posts: 10
Registered: ‎11-09-2009
My Device: Not Specified

Re: WiFi and Uma Troubles

I ran into the same problem yesterday.  Not sure if there was a tower change, or it was because of the version 5 to 6 update.  The only way I found around it for the day is to turn of the mobile network.  I don't recall if I made my "Connection Preference" to Wi-Fi only, or if I actually turned off the Mobile Network Service.  That solved the problem for the day.  However, when I left, I had to set it back so I could use it once again when I was in service on the road.