Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 5
Registered: ‎10-12-2010
My Device: Torch 9800
My Carrier: Vodafone UK

WiFi network issues

BB Torch 9800

Vodafone UK

Personal / BIS

v6.0.0.246 (Bundle 695, Platform Is this the latest?


Hi All,


I am having an issue with my Wi-Fi connection. Using the Wi-Fi troubleshoot ping utillity, I can ping a laptop from the phone, ping the phone and Wi-Fi gateway, but I cannot ping the phone from two computers on the same network.


Both phone and PC's are on the same network and the Windows firewall service is shut down on all PCs.


The Wi-Fi network is Cisco LEAP.


I was fiddling with the ping tests and it started to ping from my PC but has since stopped and I can't get it to work again. I've done several battery pulls.


I have checked the security software is disabled and there is no VPN connection set up.


I can browse the Internet from the phone (I have turned off the mobile radio).


The reason I resorted to the ping tests is to use a piece of software to allows me to browse and upload to the SD card via Wi-Fi. I should be able to start the app and go to the phone's IP in a browser from my PC.


I am not 100% sure what service books are or do, but there are two listed with 'Wi-Fi':

Wi-Fi TCP/IP Browser [BrowserConfig]

Record Type: Active

Name: Wi-Fi TCP/IP Browser


CID: BrowserConfig

User ID:-1


Gateway IP: <No Gateway>

Description: Wi-Fi Browser

Service Type: Not Specified

Service Sub-Type:Not Specified

Wi-Fi TCP/IP Transport [WPTCP]

Can't get into any other settings/info on this one.

Is there anything else I can do to test or try and resolve this?


Could it be a bug in the new OS?


I have another app that uses wi-fi and that doesn't work either. Probably for the same reason.


If anyone has any ideas I'd be very grateful if they could point them in my direction :-)


Many thanks



Guru II
Posts: 22,040
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS; PlayBook w/OS
My Carrier: AT&T

Re: WiFi network issues

If you're able to browse the web using the wifi connection then it's working.  There is no support for wifi access to the device or sd card on the device. 


What is your "other app" that supposedly uses wifi?

1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Contributor
Posts: 5
Registered: ‎10-12-2010
My Device: Torch 9800
My Carrier: Vodafone UK

Re: WiFi network issues

[ Edited ]

Hi John,


Thanks for your reply. "Not supported" or not possible? :-) The app I have installed for WiFi access to the SD card is called WiFi File Transfer by Chocolate Chunk Apps. The other one is for remotley controlling my BB from PC and is called SOTI Pocket Controller Pro.


In the original post, I mentioned that the ping did reply for a short while. During that time, I was able to browse my BB files system from Firefox on my PC using WiFi File Transfer.


I've lost my USB cable and as it's this new micro thing, I don't have any spares (yet). I'm just trying to upload some music to my phone. For some reason the DM won't work over Bluetooth (or for that WiFi). I know there is a utillity for WiFi music sync, but I still need to install the app first using a USB cable then it need integration into WMP.


Any other ideas?


Many thanks.

Posts: 15
Registered: ‎10-16-2010
My Device: Not Specified

Re: WiFi network issues

I actually am quite surprised because recently, my 2 devices, 8900 and 9700, on non-BIS dataplan but able to access wifi previously, now cannot use Wifi....


I can ping the the ISP internal routing bridges ( Meaning that I can log to the wifi access point, get DHCP working, the network is ok because my laptop is properly using it ), I can NSLookup urls using google dns ( might be able to with others but didn't try ), but I cannot access to any website, or just sometimes, for a few seconds, then kaboom. Break again.


RadioInfo state is bad, and ... basically, ... I don't know.