Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎07-14-2009
My Device: Not Specified

Wifi Connection Problem


I have a BlackBerry Bold, and I have an Orange (France) unlimited data plan with the BlackBerry Option (which cost +9€!).

The first two months, I was able to connect to the BlackBerry Infrastructure via Wifi:

white Wifi logo, third party applications working via Wifi, receiving emails...

And then, it stopped working: the Wifi logo is now grey and I do not understand why.

I still receive my emails through the 3G network, and the apps are working,

but it is not as fast as Wifi... 

I've tried registering through the Host Routing Table. Also changing the OS did not work.

I haven't got a BES, only a personnal BlackBerry.

Shouldn't the Wifi work even if I'm not on a BES?

Thanks in advance,


Forums Advisor III
Posts: 1,069
Registered: ‎04-12-2009
My Device: Samsung Galaxy S II SkyRocket (yes, Android)
My Carrier: AT&T

Re: Wifi Connection Problem

Yes, WiFi should work without BES.


The grey WiFi symbol means you have WiFi connectivity, just that you are not able to get to the BlackBerry services through WiFi.

Trusted Contributor
Posts: 142
Registered: ‎07-15-2009
My Device: Not Specified

Re: Wifi Connection Problem

Hello, this condition means that, the connectivity is out, means, detected the hardware, but just couldn't connect to the service.


maybe, you could have a check the settings of the wifi.

Original Excellent Blackberry Themes
Free Blackberry Games Applications
Excellent Blackberry Wallpapers

Also Free Android Games

All in blackberrygarden.com
New Contributor
Posts: 2
Registered: ‎07-14-2009
My Device: Not Specified

Re: Wifi Connection Problem



I tried different Wifi routers. Also I registered to Wifi under the Host Routing Table, tried different OS.

The thing is that the first two months, Wifi was working correctly (white logo, connected to Blackberry Infrastructure).

And then, it suddenly stopped working (grey logo), and now I can only use the browser with a Wifi HotSpot connection, applications, like Windows Messenger for example, are not working through Wifi.

If phoned Orange France technical service, they told me that if I haven't got a BES, Blackberry services are limited and they remove the ability to connect to BIS via Wifi.


Are they wrong? 


I know that I can receive emails and everything through the 3G network but it's so slow comparing to Wifi, and if I go out of the country, I don't want to pay a gold mine only for receiving email through the mobile network roaming.


New Member
Posts: 2
Registered: ‎11-12-2009
My Device: Not Specified

Re: Wifi Connection Problem



same problem here. my bold used to work perfectly using wifi with my home router, but after about 2 months it suddenly stopped. the wifi logo remains grey although the network shows as connected. in wifi diagnostics i see that this is a problem connecting to the BIS (blackberry infrastructure). i called both my internet provider (telecom italia) and my phone operator (vodafone italia) but neither were able to help me. if you have any luck solving your issue, do let me know.


strangely enough, the bold wifi works perfectly on other networks (starbucks, office) just not on my home network...

Forums Advisor III
Posts: 1,078
Registered: ‎05-26-2008
My Device: 8300

Re: Wifi Connection Problem

I was thinking this exact thing martinfw!


First, check if you can use the wifi for the internal network (internal website maybe?)


If so then try a website on the other side of the wifi router... (the ISP your connected with?)


Try to figure out if it is an issue with the wifi, router or just the BB data connection...



Im not sure where you go to check, but this wil help you narrow down where the issue is...


Checked out my Blackberry FAQ's and Links to Needed Articles here