Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 3
Registered: ‎08-20-2011
My Device: Blackberry Torch 9800
My Carrier: MTN South Africa

Wifi unable to switch on`

Hi All,


Sine Tuesday night when my battery died, the Wifi on my device doesnt work (I left the app world open which ran it down). Whenever I switch the wifi on, it says that it is unable to turn the wifi on. I left the battery out for half an hour on THursday night which seems to have worked for a while, but the problem  has manifested itself again. I have done a security wipe and re-installed the latest software.


I somehow dont think that it's hardware related otherwise it wouldnt work, would it? My blackberry maps also dont work and it says that the GPS is unavailable. Can it have something to do with the Wifi?


We have 3G where I live most of the time, but the Wifi is just so much faster using my broadband connection at home. I contacted bb support and have not received any assistance. My carrier seems to think that it's hardware related, but I dont think so.


Your assitance will be much appreciated!



Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: Wifi unable to switch on`

Hi mark13077


Are you activated on a BlackBerry Enterprise Server? Check under Options>Security>Security Status Information to see if you have an IT Policy listed.







Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

New Contributor
Posts: 3
Registered: ‎08-20-2011
My Device: Blackberry Torch 9800
My Carrier: MTN South Africa

Re: Wifi unable to switch on`

Hi Capt - awesome name BTW

No, I don't have BES.

Any other suggestions? I pulled the battery for a few hours on Saturday night and on Sunday it worked again for about 20 mins and went off again. I'm at my wits end now. Lol


PS - any other suggestions?