Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 3
Registered: ‎12-21-2008
My Device: Not Specified

Wifi very slow, often get "communication failure" message

[ Edited ]

I'm at wit's end trying to figure out what's wrong with the Wifi browser on my BB bold.

 

I use the Internet Browser to surf the net, and it's very slow to load pages -- often more than a minute to load a page.

 

Mostly, it just hangs and doesn't work. The blue progress bar will close to the end, and then I get this message: "A communication failure has occurred. The server may be busy, please try again later. If the problem persists, contact your service provider."

 

So far in four weeks that I've had the phone, I've found 3G to be much faster, and I never get the "failure" message. Shouldn't Wifi be faster?

 

I've tried a number of things, all to no improvement:

 

- Clearing the cache, cookies and history (no difference, still hangs just after I clear)

- going to hotspot login, and logging in or pressing "start BB connection" (this works at first -- a page will load very quickly and then after that, it gets slow, and then I get the "communication failure" message)

- turning off javascript (which I did from the start)

- restarting

- battery pull

- resending service books

- wipe and restore

- resetting/restarting my wireless router (which is open, no password)

- doing the register "wifi[60]" thing referred to in another thread

 

I'm using the latest official OS, 4.6.0.162, English version, on Taiwan Mobile. I have no problems receiving email on my phone, the Wifi icon is usually lit up in white -- and  'service status' says BIS is connected to Wifi.

 

It's really frustrating -- since I got the phone I haven't had one smooth experience browsing the Web over Wifi --

 

Any help or suggestions appreciated!

 

 

Message Edited by davidwoohoo on 01-24-2009 06:23 AM
New Contributor
Posts: 3
Registered: ‎12-21-2008
My Device: Not Specified

Re: Wifi very slow, often get "communication failure" message

I solved this problem when I changed Wifi routers. We switched from an old Gigabyte router to an Apple Airport Express. But I still don't understand why the old router wouldn't work. All other wireless laptops, ipods and PDAs at home worked just fine.