Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 9
Registered: ‎10-02-2009
My Device: Not Specified

WordToGo error

I've been having an issue with WordToGo in my Blackberry 8310 Curve running on v4.5.0.163 (BIS) bought directly from AT&T.

 

I bought it in v4.2 and when I updated it, I didn't get Documents To Go because I forgot to check it. I decided to reinstall it, and version 1.000.080 was set inside my phone. When I tried to open a Word document, it came up with the following messages:

 

"The application WordToGo has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT policy."

 

"Permission to your files was denied. Please configure your application permissions appropriately."

 

I decided to read up on this, and several solutions appeared in many forums. Some said I had to Options -> Security Options -> Application Permissions -> Click Menu button on Documents To Go -> Edit Permissions -> Set everything to "Allow" and then go down to where it says "WordToGo", click the Menu button above it and go to Module Permissions, and set all to "Allow", and finally click on "Reset Firewall Prompts".

 

I was told that after doing this and resetting the phone, it'd work. It didn't. Then suggestions attacked the IT policy. I'm on BIS, but going to Options -> Security options -> General Setting, there are two things listed under "Services":

 

1) BBFS1 [GTALKNA1] (AES)

2) WLM 2.1 [WLMA01] (AES)

 

Neither of those are IT Policies, because I have both Google Talk (#1) and Windows Live Messenger (#2) installed in my BlackBerry and i think these services belong to those apps. i might be wrong here, so correct me if so, but since I don't think these were the source of the problem at all, I decided not to touch them.

 

Then came the people who said I needed to upgrade everything for heaven's sake. Great, I have the latest OS for the 8310, so all it took was to update Documents To Go. I did so through Slideshow To Go, using the update check, and downloaded Documents To Go 1.007.0, which in turn also gave me Sheets To Go. It's important to note that both Slideshow To Go and Sheets To Go work seamlessly and without issues, the real problem is with Word To Go.

 

Finally, then came the people who told me to reset the OS and reinstall everything again from scratch. I'm not willing to do that yet, because resetting the phone just for one app that should work to begin with is just wrong. I use the Standard edition so there's no money at stake, but I'm still really pissed at not being able to determine what the source of the problem is.

 

Yes, I also uninstalled and reinstalled/reupgraded Documents To Go several times, also Editing Permissions every time.

 

Oh, and there was one last suggestion, which was to turn of the Firewall. I can't turn off the firewall, there's a little red lock beside it.

 

 

As of now, I've hit a roadblock. Can anyone help me with this? Is there any official diagnosis of this problem made by RIM yet? Or is it still obscure? I truly am desperate, i've tried everything except for a complete Handheld Wipe, which I want to avoid as much as possible.

 

Help please :smileysad:

Guru I
Posts: 19,020
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: WordToGo error

I understand you are trying to open a document with wordToGo. Where is the file located ? Can you try moving it to another location ?




The search box on top-right of this page is your true friend, and the public Knowledge Base too: