Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 3
Registered: ‎09-20-2011
My Device: blackberry z 10
My Carrier: 02

bold 9900 media card not inserted in device

my blackberry 9900 says there is no media card inserted in device  but it is 

inserted  .  i have formated it on pc  pulled the battery  and anything else i could try that has been recommended

the card is recognized on pc 

it is my card from my old blackberry which it worked fine in 

can anyone help please 

New Contributor
Posts: 2
Registered: ‎09-21-2011
My Device: Bold 9900
My Carrier: Rogers

Re: bold 9900 media card not inserted in device

I have the same problem.  media card works in my BB Torch 9800 but when I insert it into the BB Bold 9900 it does not recognize it...

Contributor
Posts: 16
Registered: ‎09-20-2011
My Device: 9700 Bold
My Carrier: Vodafone NL

Re: bold 9900 media card not inserted in device

What you could try is go to options > memory. Press the options key and press format and or repair.
Don't know for sure if it will fix it but it's worth a shot.
New Contributor
Posts: 2
Registered: ‎09-21-2011
My Device: Bold 9900
My Carrier: Rogers

Re: bold 9900 media card not inserted in device

Since my Bold does not recognize my media card, the only options I have to repair/format is for the internal memory - not the media card.

 

If I take the media card out and put it in my torch, it works...

Contributor
Posts: 15
Registered: ‎09-03-2011
My Device: Bold 9900
My Carrier: O2

Re: bold 9900 media card not inserted in device

I had the same today with my 32gb card and bold 9900. I ended up formatting the card as exFat on a pc then popped it in the phone, which asked me to format it. I did and it works.
Contributor
Posts: 15
Registered: ‎08-13-2010
My Device: Bold 9700
My Carrier: Vodafone

Re: bold 9900 media card not inserted in device

[ Edited ]

I have the same issue with media card not being recognised, but mine is caused by the charging method.

 

When on charge via PC and it rings, if I unplug and take the call, when I try to do anything where the phone needs access to the media card, I get an error.

 

I either have to power down and back up again or go into OPTIONS>>DEVICE>>STORAGE and then press the BB button and click disconnect, then the error disappears and the card reappears as available.

 

This is obviously something to do with just unplugging the device straight from charging via PC, without disconnecting or close the desktop software, but it is a pain and can't be helped if it is on charge when it rings.

 

When it is taken off charge quickly, it should switch back to the media card option and not stay on the PC connected option

 

Anyone have any ideas how to stop this happening when disconnecting?

 

I have already asked the question in a new thread, but I have not been getting any answers to the problems I am having with this new BB. I will avoid being an early adopter in the future. The only function that worked first time was the Bluetooth, but it seems I have been lucky, as others are reporting errors with that connection also

New Contributor
Posts: 4
Registered: ‎10-28-2011
My Device: curve 9300
My Carrier: Vodafone

Re: bold 9900 media card not inserted in device

I have the same problem and cant figure it out.  Any ideas anyone?

New Member
Posts: 1
Registered: ‎08-30-2012
My Device: Bold 9900
My Carrier: Claro

Re: bold 9900 media card not inserted in device

The files are not lost, when ever you do a repair, it generates a duplicate folder "Blackberry" and thats the reason your divece cant read them, the only thing that you have do is open the media card on your pc and do a manual back-up and then delete the duplicate folder "Blackberry", unplug the divice from the pc and restart it with left "Alt"+"Shift"+"Del" and you will be able to locate your files Smiley Surprised) it worked for me!!
New Contributor
Posts: 2
Registered: ‎03-13-2011
My Device: blackbarry 9780
My Carrier: t-mobile

Re: bold 9900 media card not inserted in device

[ Edited ]

Same problem with my 9900.
Has anyone noticed what preceded the problem (installing hybrid, upgrading OS, physical impact, etc)?

New Contributor
Posts: 2
Registered: ‎01-19-2013
My Device: bold 9900
My Carrier: vodafone

Re: bold 9900 media card not inserted in device

I have the same problem. The media card worked fine on other devices. I can see the device memory while connected to the PC . But the phone storage options don't show the card at all. In fact the card is inserted but the mad phone says that there is no media card. Have tried everything including upgrading and downgrading the software, pulling the battery, formatting the card on a PC, trying other lesser memory card.... Nothing worked.


paulpru wrote:

my blackberry 9900 says there is no media card inserted in device  but it is 

inserted  .  i have formated it on pc  pulled the battery  and anything else i could try that has been recommended

the card is recognized on pc 

it is my card from my old blackberry which it worked fine in 

can anyone help please