Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎08-24-2014
My Device: Blackberry 9930
My Carrier: Sprint

buying on app world

Hi I have this problem of trying to put in my card info and no matter how many times I put a different cards in it saids invalid card please help
Hall of Famer III
Posts: 57,243
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAF518), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: buying on app world

Hi and Welcome to the Community!!

Please double check your PayPal account -- log into it from a PC/browser and ensure that the credentials you use there are identical to those you use to log into MyWorld. Also ensure that all credit cards you have attached to PayPal are current and valid...we have learned that if there is any credit card attached to your PayPal account that is invalid for any reason (e.g., expired), it will prevent AppWorld purchases from completing, even if it is not the funding source. Further, there must be at least one (valid) credit card attached to the PayPal account.

We also have heard from some users who report that creating a whole new PayPal account somehow fixes things and allows them to make purchases. I'm not sure why that works, but reports exist that it does.

Also please try a hard reset: With power ON, remove the back cover and pull out the battery. Wait about a minute then replace the battery and cover. Power up and wait patiently through the long reboot -- ~5 minutes. See if things have returned to good operation. Like all computing devices, BB's suffer from memory leaks and such...with a hard reboot being the best cure.

In addition, you can try this sequence:

1) Remove AppWorld from your BB

  • KB10040 How to view or remove installed applications on a BlackBerry smartphone
  • If it requests that you reboot the BB, do so

2) Do a Batt-Pull reboot (power on, remove battery, wait, insert battery, wait), even if redundant to the one you did in step 1.

3) Install (on your BB) a fresh copy of AppWorld

4) Do another Batt-Pull reboot

5) See if it now works.

Cheers!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................