Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 2
Registered: ‎05-19-2013
My Device: Blackberry 8120 v4.3.0.39
My Carrier: simyo

need Whatsapp on BB 8120 wit OS 4.3.0.39

hello Forum, since a long time I try to install Whatsapp on my BB 8120 but for this i need to Update my OS to 4.5 ... But its not possible. I just can download some BB Suite or BB Applications that just reconize the newesd Blackberrys but not my 8120. I download already 3 diverent Software but nothing is bale to change the OS. The secend issue is, that i can not find realy the OS 4.5 for download.

I have a Mac - what i found yesterday was a OS 4.5 download in a EXE file.

 

Please can you help me because I spend a lot of time already for a thing that should be done in 20 minutes.

Where can i download the OS4.5 ( i have a Mac) and how can i installed on my BB?

 

Thanks a lot for your help.

Best Regards

 

PS: In the Message TAGS' s i used the word "on" and its not allowed in this forum? why?

 

 

Hall of Famer III
Posts: 57,565
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: need Whatsapp on BB 8120 wit OS 4.3.0.39

Hi and Welcome to the Community!

 

App compatibility is a matter of both specific device model number as well as major OS level...each developer must port their app to all combinations thereof if they are to support everything possible. Most developers choose not to do that and only support a subset. If the app you desire requires a specific minimum OS level on your specific device model, then you can't use the app until you can be running a compatible version. Please check the app compatibility requirements carefully to ensure that both your specific BB model number is supported as well as to discover the OS level that is required.

 

But, as you discovered, there is less flexibility when doing OS loading via MAC...with MAC, you are restricted to only your carriers sanctioned OS packages...but can still use any levels that they currently sanction. See this procedure:

  • KB19915How to perform a clean reload of BlackBerry smartphone application software using BlackBerry Desktop Software

The OS download files are useless to you on MAC, and you cannot use an OS that a different carrier may have released. All of those tricks require PC...not MAC. So, on MAC, you can only use what it tells you. If that's not adequate to enable compatibility with the app, then you will have to abandon the use of MAC for your device OS updating and instead gain access to a PC in order to do what is needed.

 

Good luck and let us know!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 2
Registered: ‎05-19-2013
My Device: Blackberry 8120 v4.3.0.39
My Carrier: simyo

Re: need Whatsapp on BB 8120 wit OS 4.3.0.39

Thank you for your Help! I wil try with a PC and try to follow up the Link you send. I will keep you infromed. Greetings