Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 14
Registered: ‎05-18-2013
My Device: 8520
Accepted Solution

.voip.blackberrry.com Untrusted

One royal pain in the butt


I joined this service expecting that BB technicans will provide a solution. 

I'd prefer a straight forward reply. I'm not looking for an education on what a certificate is, if you get my drift


I have a 8520 unlocked bought about a year ago from Amazon

OS v5.0.0.781 (Bundle 1168, Platform

I live in Panama

The provider here is Movistar


Suddenly about a week ago I started getting this message about "untrusted certification"


the heading on the message is: * .voip.blackberry.com Thawte SSL CA untrusted

or something to that effect



CN= x*.voip.blackberry.com


O= Research in Motion




CN= Thawte SSL CA

O= Thawte Inc

Serial No: 1678rF1BFB86F194CAFC7433AA89432A


unverifiable Cert Chain

Untrusted Cwert Chain


Expiration: Nov 9, 2013

Revocation Status: Unknown

Trusted Status: Not Trusted

Certificate Type: X509

Public Key Type : RSA2048


I've written Thawte and they don't even know what I'm talking about, it seems.  They seem to think I can connect to my PC using my BB PC Tool (forget the name) and some how install a new certificate.  They are in zip formate for one and when I point BB Software to upload it fails.  I think then they wanted me to sync that certificate.  Or a get advice that it's not their problem, something about the server.. who's that my internet provider?


I read several messages similar to my problem on this and other services. 


I tried "wiping" my BB.

It took me forever to restore everything, I finally did but I still have the problem. Yes maybe the problem is in the backup up I don't know what feature of the backup to avoid if in fact a restore from a back up is a solution. At this point I created a Keystore password" which I didn't have at the beginning of this mess. Little good it does me though


I sort of get the impression this is a problem with wifi. That's a guess from what I've been reading.



PLEASE no responses like " you might try this" or "maybe this is your problem"


somebody at BB must have a handle on this, NO?

Posts: 14
Registered: ‎05-18-2013
My Device: 8520

Re: .voip.blackberrry.com Untrusted

I think it requires removing Blackberry Messanger which I apparently gave it permission to include "voip" but that my provider doesn't support.

Problem is BBM is a core application and I can't find a way to delete it... gees one more headache after another
Posts: 14
Registered: ‎05-18-2013
My Device: 8520

Re: .voip.blackberrry.com Untrusted

I learned you can go to "add on" in the Application section of setup and there you can remove Blackberry Messenger

Will this resolve my original problem?  I'm waiting to see... 10 min after reboot so far and no alert that certificate needs permission.. 10 min later still no alert message..


I think this resolved my issue.


I've spent days on this!


No help what so ever from anyone at Blackberry or responses here.


Is that interesting?


I could have avoided a lot of this BS on my BB if I'd known from the start that BBM was the heart of the issue