Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Member
Posts: 1
Registered: ‎12-25-2011
My Device: Playbook
My Carrier: rOGERS

Re: PROBLEM SOVLED? Blackberry Desktop does not see Playbook when connected USB

You've got to be kidding me?!!  8 pages of posts about drivers, start-up sequences beginning 9 months ago and nothing at all from RIM?  As a Canadian I am very disappointed in this **bleep** and it has just ruined my Christmas Day.  I expect a full refund.  If anyone knows why I can spend two hours doing ALL OF THE ABOVE and still not make any progress, I'd be happy to hear it, but apart from that, it goes back tomorrow.  No wonder these things are on firesale!

New Member
Posts: 1
Registered: ‎01-01-2012
My Device: Blackberry Playbook 16GB
My Carrier: 3

Re: Blackberry Desktop does not see Playbook when connected USB

Thanks for this - solved my problem perfectly after hours of annoyance.
New Member
Posts: 1
Registered: ‎01-05-2012
My Device: Curve 8520 - 32G Playbook
My Carrier: Bell

Re: Blackberry Desktop does not see Playbook when connected USB

Had all the same issues. Reinstalled, uninstalled, etc. Turned off wifi on the PB and it worked. Turn off the wifi when connecting to a computer.

Posts: 13
Registered: ‎03-01-2009
My Device: Torch 9800
My Carrier: Various

Re: Blackberry Desktop does not see Playbook when connected USB

I have Win7 64bit and finally got mine to recognize my PlayBook again.

It was working as of Jan 2, 2012 but Jan 6, 2012 DM would not connect.


Here is what I did after 2 hours of searching and trying:

1. Connect PlayBook and open DM

2. The PlayBook information is in the background in DM but says it can't connect (Retry, Update, Cancel) so I clicked cancel

3. I then clicked File and Forget Device.

4. I disconnected and reconnected the PlayBook

5.  DM found the PlayBook and we're back in business

New Contributor
Posts: 5
Registered: ‎01-30-2012
My Device: Bold 9900 - Playbook
My Carrier: Truemove

Re: Blackberry Desktop does not see Playbook when connected USB

I still have no success with all of the above. The BDM can recognize my Playbook's PIN but it still shows the pop-up that  "Blackberry Destop Software cannot communicate with the connected device" - "If the device is rebooting or has a dead battery....bla bla bla...."

I've already tried to turn off wifi/Bridge and restart, disable antivirus/firewall, re-install BDM (newest v7.0.0.32), Select all when going to Local Area Connection (RIM) properties,... NO success.

I'm running OS 1.0.8 on my Playbook. Windows 7 Home (x64)

Any more advice? Tkz 

Guru III
Posts: 32,144
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Blackberry Desktop does not see Playbook when connected USB

the playbook does not use mass storage mode

it maps a network drive to your pc which means there are more places for it to mess up

there is no one fix as computers have many different cards, protocols, connections, firewalls, security software, network access and who knows what else installed.

there are a lot of tips in this thread that have helped others but not all of them are going to be your cure


Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

New Member
Posts: 1
Registered: ‎01-31-2012
My Device: Bold 9900 + Playbook
My Carrier: Orange France

Re: Blackberry Desktop does not see Playbook when connected USB

Hello all,


I think I found a real working solution !!!!  

At least it works for me which is good as this thing was driving me crazy.


I'm on Windows XP SP3 but I think it is the same story on other Windows versions.


The point is that the Playbook is NOT a USB Mass Storage device. You must see it as a Network Device that happens to communicate through USB.


I was messing with the same things I could read in the previous posts when at a point in time I decided to look at the networks adapters (Start-Settings-Network Connexions) and I noticed a new network adapter that appeared when you connect the Playbook to the PC and the Playbook goes "Connected to Computer". The new Network adapter is called "Research In Motion blah blah blah".


If you go to Right-Click on this network connexion and select Properties, you will see 3 connexion items: 

- Client for Microsoft Networks

- File and Printer Sharing

- Internet Protocol (TCP/IP)


These 3 items were unchecked. I checked the three of them and all the sudden, everything started working like by magic (Desktop manager etc....)


I believe of course File sharing and all must be activated on the Playbook. It is as simple as this. For some reason, the installer installs everything but forgets to check these 3 boxes....


Tell me if it works for you.





Posts: 17
Registered: ‎02-16-2012
My Device: Playbook
My Carrier: none

Re: Blackberry Desktop does not see Playbook when connected USB

those are already checked.

no matter what I have to turn off WIFI. sometimes it requires restart my Playbook,

Its really annoying. I hope the new OS 2 will fix this issue.

New Contributor
Posts: 9
Registered: ‎01-01-2012
My Device: Playbook
My Carrier: Telus

Re: Blackberry Desktop does not see Playbook when connected USB * Working Soulution*

[ Edited ]

I've had issues as well. It was working fine and then al of a sudden it wasn't..was perplexing as I have a few computers here and I had installed the beta version 7 of desktop manager on another 32 bit computer with win7 on it that still connected fine..though a little strangley..it shows up as a network device..but it still works and I can access the Playbook.


But on my other system, which is a 64 bit computer running win7 is where I really started having issuses.


I tried reinstaling the Dektop Software to no avail..tried totally uninstalling..finding (hard to find btw) the beta version of DTSoftware from BlackBerry and still no go.


Kept getting a 'failed device driver' notification as well and at one time my device manager informed me that me ' Blackberry Smartphone' had suscessfully been installed ??


Odd..I got to thinking that it was a device manager or driver issue and noticed on the 32 bit computer that worked the version of device manager was yet the version that was on the other computer was that didn't work


So I figured I needed to find that device driver but no where on Blackberry's site can it be found! Though I'm sure its there..


Apparently its on the playbook itself..when its initially plugged in it mounts as a cd drive and installs its own driver and thats where it is.. though its inacessable to the average user


So somehow mine had become corrupt..suprised Blackberry is not aware of issues like this and doesn't have an updated version..or even older versions for different computers of the device driver available for download!


Anyways to sum it all up and end alot of frustration..I ended up uninstaling the Desktop Software from control panel AND going into Device Manager (Device Manager in Windows..Control Panel\System and Security\System\Device Manager) and uninstalling the acual driver for the device by right clicking on it and uninstalling the  'RIM Network Device' from the 'Network Adapter' tab


The Tablet may have to be plugged in to see this ^^


Rebooted, plugged in the Playbook, still got a wierd error about a device driver failing but after installing Desktop Software (6) again now all is well and I have a Blackberry Device Manager Icon in my task bar now showing it connected and using version 6.00.40


Pain in the **bleep**, but I have been playing around with a few different playbooks here,among other things Smiley Wink  ..one was a 32 gig but I returned for a 64..maybe there was some issuses with that or maybe there was a corrupted device manager on one of the playbooks beats me, but ti's fixed now.


But Like I said, there really should be a download area to access these files in case things go wrong, everyones computer config is different.


Oh and I tried that 'turn off wifi' thing and it didn't help..have it on right now (with password) and always have and connects fine both WIFI and USB


Hope this helps someone.


Cheer! Still love my Playbook, especially with os 2 !

New Contributor
Posts: 9
Registered: ‎01-01-2012
My Device: Playbook
My Carrier: Telus

Re: Blackberry Desktop does not see Playbook when connected USB

After looking at the previous post I may have had to reboot my Playbook as well after starting Dm..So that may need to be done as well