Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
New Contributor
Posts: 4
Registered: ‎04-25-2012
My Device: Blackberry Playbook
My Carrier: Lime Barbados

Camera not working since upgrade

I recently upgraded to 2.0.1.358 from 2.0.0.7971 and the update process went through smoothly. However, after the upgrade, neither of my cameras work and when i launch the camera app i get an alert window with the following message: 

"Camera Error: The camera is in use. Close any other instances of the camera and try again" 

 

I did a security wipe, and also reloaded the OS through the desktop software, neither of which helped. The cameras dont work when i open video chat either,

 

Searching the knowledge base i found one article which was of no help.

Knowledgebase Article

New Contributor
Posts: 2
Registered: ‎04-27-2012
My Device: Blackberry Playbook
My Carrier: Bell

Re: Camera not working since upgrade

Same thing here

I also tried going thru my security settings and denying all of the apps that used the camera which didn't help

T_T

Forums Veteran I
Posts: 1,945
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860, Z30
My Carrier: Wind Mobile

Re: Camera not working since upgrade

Have you by any chance downloaded some of the Photo Apps? It almost appears that some program is locked onto the camera app. Isn't a Security Wipe supposed to wipe all added files except for the OS. Have you tried the three button reset? This is similar to Control - Alt - Delete on the computer. Hold down the Power Button and both volume buttons at the same time for 15 seconds and then wait 1 minute then hold the power button only until the red light flashes then release it and wait for the PB to reboot which will be about 4 minutes. Try it and let us know.
New Contributor
Posts: 2
Registered: ‎04-27-2012
My Device: Blackberry Playbook
My Carrier: Bell

Re: Camera not working since upgrade

Srry

Ive tried the reboot

And the app works but when i go to switch cameras the screen turns black

Then, when i close and reopen camera it shows that message again

"the camera is in use. Close any other instances of the camera and try again"

Ive also just deleted my qr scanner that also uses the camera rite after i rebooted my playbook

Same results

Forums Veteran I
Posts: 1,945
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860, Z30
My Carrier: Wind Mobile

Re: Camera not working since upgrade

Here is some bad news I just found. Google it. KB30341
New Contributor
Posts: 4
Registered: ‎04-25-2012
My Device: Blackberry Playbook
My Carrier: Lime Barbados

Re: Camera not working since upgrade

[ Edited ]

I also tried the reboot without success. The only camera app I had before the upgrade was pencil camera and haven't used that in weeks.

 

About half of the time I also cannot get he video chat app to work since this happened and the knowledge base article is the same one I linked to in my original post. There are a few otherpeople experiencing this same issue on crackberry forums and only some of them found success by downgrading back to 7971 but hat didn't work for everyone. 

 

I also just noticed that the two volume buttons don't take a screenshot anymore...well it took one when I tried thereboot butit isn't working now.

Forums Veteran I
Posts: 1,945
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860, Z30
My Carrier: Wind Mobile

Re: Camera not working since upgrade

Why don't you delete the pencil camera ( you can easily reinstall it again)and do the 3 button reset again.
New Contributor
Posts: 4
Registered: ‎04-25-2012
My Device: Blackberry Playbook
My Carrier: Lime Barbados

Re: Camera not working since upgrade

Its not on anymore. I have done about 3 security wipes and about 3 OS reloads from the desktop since i first experienced the problem.

New Member
Posts: 3
Registered: ‎04-27-2012
My Device: PlayBook 2.0.1
My Carrier: N/A

Re: Camera not working since upgrade

I never had this problem I suggest let the battery drain then charge it and turn it on then try make sure you have no apps that use the camera except camera,video camera, voice chat and system apps. Should work. If not try downgrading. Wipe, do the reboot lost_at_sea said and upgrade through desktop software. Also check if. 2.0.0.7971 the camera works,if not camera/driver is spoilt.
Forums Veteran I
Posts: 1,945
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860, Z30
My Carrier: Wind Mobile

Re: Camera not working since upgrade

I just checked the Pencil Camera App. I didn't download it. It is highly rated with no negative comments so I don't think the problem is there. Wiping and reinstalling on the DM should have resolved the issue. I suggest you contact RIM.