Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Contributor
Posts: 8
Registered: ‎11-27-2012
My Device: playbook
My Carrier: bell

Can't Back up the Playbook

[ Edited ]

My BBID is so screwed up I can't fix it. So a wipe is next. Problem is, the back up will not work: message is "an error was encountered - check to make sure it is connected and turned on". Am I that stupid? That I would try to back up the playbook without connecting it?


Without doubt, RIM deserves to be put out of its misery for the crappy product they foisted on us. Incredible.

Posts: 863
Registered: ‎10-27-2010
My Device: Z30 / PlayBook 64GB
My Carrier: Virgin Mobile UK

Re: Can't Back up the Playbook


Try to remove apps that you don't need save data for. Some apps have been known to stop the backup from working, and when it happened to me I did this to get it working.

I never pinned down which one was causing the problem.

I'd also suggest seperating your app and settings / data backups.

Follow me on Twitter1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
Posts: 210
Registered: ‎05-18-2009
My Device: NA
My Carrier: NA

Re: Can't Back up the Playbook

[ Edited ]

Keep coming here hoping someone has found a simple fix or RIM has decided to actually invest effort into this 1 year old bug.  But I keep forgetting that RIM has never (and will never) be known for fantastic support and has a habit of leaving many customers in the dark.


Sounds dumb but:


  • Backup Media & Settings separately
  • Disable WIFI on your PB (prevents the 100byte failed backup message from 2/3 to 1/3 times)
  • Remove all apps you have no game save data for (in my case it means removing about 11GB of apps.  Thanks rim)
  • Try to backup whats left for apps (7GB in my case)

Note:  You can secure wipe on the PB (dont do it on a Dev Alpha as it bricks the device, another good rim job) to resolve this issue temporarily


  • Your backup will still fail a lot, keep removing apps.  The application count will usually be wrong, indicating ther is still a problem
  • Once you have a successful backup, make a second.  I find up-to 2/3 backups will actually be corrupted when you try to apply them


Eventually you will have a backup, and it may actually be uncorrupted.  Apparently this happens because applications do not fully install or remove themselves, and RIM has some hack job method of backing up your PlayBook apps, so if you install and remove apps on any kind of a regular basis - you'll eventually end up exactly where you are.


I'll come back to the forums in another 2 months to see if they resolved it.  But considering having dealt with their completely useless support many times, and having looked for solutions for 12 months, I've just about given up on them.  Just hope you never need to migrate PlayBooks like I seem to be stuck doing quite frequently.