Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Highlighted
Developer
Posts: 863
Registered: ‎10-27-2010
My Device: Z30 / PlayBook 64GB
My Carrier: Virgin Mobile UK

Clever Clock Fix Anyone?

OK - this has been irritating me for some time now.

 

The Clock app on the PlayBook isn't working properly. When the clock loads - it doesn't display the clocks until I swipe down and create a new clock. This has the added side effect of making lots of invisible clocks that I can't select take up space.

 

I've narrowed it down to the clock.sqlite database in the app folder.

 

Of course, since then RIM have been encrypting backups so I can't do anything about it - and before I had trouble because whenever I edited a file in the backup and restored it - the app wouldn't start.

 

So here I am. I'm stuck.

 

I've tried manually deleting the app with the developer tools but that won't work.

I can't wipe the PlayBook because I'll lose all of my data, and after a restore from backup I have restored the clock with the bad settings anyway.

 

If this were a BB handset there wouldn't be an issue. I could remove the app through the apploader or desktop manager. You can selectively add/remove/restore apps but on the PlayBook it's "All or Nothing".

 

I'd appreciate any genious ideas to fix this one.


Follow me on Twitter1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!