Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Contributor
Posts: 2
Registered: ‎01-13-2013
My Device: Blackberry 9900
My Carrier: MTS

Couldn't resolve the host name (AGAIN!!!!)

I get this error alot! I've searched all kinds of forums and tried so many things that sometimes work (e.g., clear cache, restart). This is a common problem that renders the Playbook useless. It's so frustrating when you need to quickly jump online to check something and have to spend 20 minutes troubleshooting. What's the point?


According to my Wi-Fi tab, I'm connected and everyone else in the house is able to access the Internet without a problem (they have Apple products, I'm an die-hard but slightly embarrased RIM fan).


Does anyone know how to get around this error? 

Trusted Contributor
Posts: 167
Registered: ‎05-03-2012
My Device: playbook
My Carrier: n-a

Re: Couldn't resolve the host name (AGAIN!!!!)

I had a ton of problems on an older router..

First off: _if_ your router does not support AES, then set encryption to 802.11 g only instead of g + n. The Playbook has a security rating that prevents 802.11n and TKIP, and this causes connection problems (in my case it would crash the router for everyone). Most of the apple devices were connecting in g anyway. Some of the laptops were connecting with n, others g. You get slightly faster streaming with n but the stability was way better.

I then had a lot of problems with the Playbook losing its connection and failing to reconnect. We had a LOT of wireless devices running at the same time and every time my phone (an iPhone) rang, the Playbook would stop working. It turned out to be an interference problem - I changed the channel setting and this fixed the problem. We had less instances of browsers not finding the server momentarily after that too. Seems all of the devices were losing their connection to the network for a moment or two but only the Playbook had trouble reconnecting.

Hope this helps. Good luck - I've felt your pain and survived Smiley Wink
Super Contributor
Posts: 349
Registered: ‎01-02-2013
My Device: pb
My Carrier: none

Re: Couldn't resolve the host name (AGAIN!!!!)

"Could not resolve host name" is a DNS problem. Could be your ISP, could be cache.  

You could set a fixed IP address in the network saved connection,  high up in the range of your router (e.g. 192.168.x.150) and then set  DNS servers like Google and and see if that helps. 

Trusted Contributor
Posts: 105
Registered: ‎11-28-2012
My Device: PlayBook
My Carrier: 3 it

Re: Couldn't resolve the host name (AGAIN!!!!)

a little workaround is create a wlan between pc (maybe with an external adapter) and playbook and use it as normal wireless connection
New Contributor
Posts: 2
Registered: ‎01-13-2013
My Device: Blackberry 9900
My Carrier: MTS

Re: Couldn't resolve the host name (AGAIN!!!!)

Thanks...I had a pretty good run but I'm having the same problem again so I will try these suggestions and report back.

Guru III
Posts: 32,226
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Couldn't resolve the host name (AGAIN!!!!)

Last time I had this issue was at a hotel and kept tapping the link and it worked


At home I switched to opendns.org as my ISP DNS was overloaded


Look at my tips on wifi



Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

Posts: 1
Registered: ‎10-10-2014
My Device: Playbook
My Carrier: ROGERS

Re: Couldn't resolve the host name (AGAIN!!!!)

my playbook has this error/problem the last few days but never before.   Once in tens of tries it would work for a few minutes and then the same error.  ie no web access.

i tried clearing the cache but does not work.  do you have the same problem still?  what was the solution?