Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
New Contributor
Posts: 8
Registered: ‎02-21-2012
My Device: BlackBerry Playbook 16GB
My Carrier: Verizon Wireless

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

The fact that the native mail application DELETES emails from the server when you delete them from the PlayBook ALTHOUGH the 'Leave Messages On Server' is set to ON.  This needs to be fixed!  These messages should remain on the server NO MATTER WHAT you do with them on the PlayBook with this option set.

Regular Contributor
Posts: 66
Registered: ‎01-22-2012
My Device: Torch 9800, Playbook 64
My Carrier: AT&T

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

Volume +,- buttons work sporadically.

 

Change black "X" to close tabs to either red or white.  Black tends to blend into the background and makes hitting the close harder.

 

I would prefer to have my Contacts imported or loaded as "native" instead of being held hostage to phone or network sync activities.  Prefer to update/sync at my own choice.

 

Mentioned in another thread:

I am unable to do a search of App World on the PB.  Nothing happens when the search icon in the dialog box is activated.

 

Overall, I'm quite pleased with OS2 and the PB and can use it without above changes if necessary.

Forums Veteran I
Posts: 1,625
Registered: ‎02-28-2012
My Device: Two PB's

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

Bug with exchange activesync that makes syncd mails disappear from PB mail when wifi disconnected or bridge used.
_________________________
New Contributor
Posts: 2
Registered: ‎02-28-2012
My Device: Playbook 64GB, 32BG and a z10 and z30.
My Carrier: Telus

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

For #4, swipe down on your home screen for Settings then choose Visual Notification. Change to LED only. Yes, the corner is distracting when it's always on.
New Contributor
Posts: 5
Registered: ‎03-06-2012
My Device: Torch 9850 - PlayBook
My Carrier: USCellular

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

[ Edited ]
Bug - Browser crashes too often. No rhyme or reason. Bug - When trying to paste a link in a forum post you can not because the option to paste is underneath the box and no way to bring it forward. Bug - Native email - When all emails are deleted from the inbox the next received message will have the new header but the body of the last deleted email. The way I found around this is to either leave 1 email in the inbox or move the messed up email to a different folder or close and reopen the email app. Request - Universal search. Request - Mail to: option. Request - IM/Video chat that works with all major clients. Does not lose connection when it is not the focus and makes use of notifications. Enough of the proprietary stuff. Request -Bookmarks in the browser need to able to be renamed and able to sort. Also a way to change the user agent. Request - More file types supported, all around. Request - A PDF Reader that can search, annotate etc.
New Contributor
Posts: 2
Registered: ‎04-18-2012
My Device: Playbook
My Carrier: O2

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

Bug:

The browser does not appear to be handling headers on follow on post requests.

Specific error message recieved from a lacinema hd on my local network.

409: Conflict

Your request had an invalid session-id header.

To fix this, follow these steps:

  1. When reading a response, get its X-Transmission-Session-Id header and remember it
  2. Add the updated header to your outgoing requests
  3. When you get this 409 error message, resend your request with the updated header

 

This requirement has been added to help prevent CSRF attacks.

X-Transmission-Session-Id: 1IdThlnPlqUjEK5S6CuUTtYovBNc1pHaCKBHNORIgzkM1s4d

New Developer
Posts: 12
Registered: ‎11-10-2011
My Device: Z10
My Carrier: not important

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

For me there are only two things really annoying:

 

1. If I want to clean the touch screen when the PlayBook is in Standby it wakes up if I swipe from the bezel sometimes. The same happens if the PlayBook is in the sleeve.

2. Sometimes if I have open apps in the background the battery is drained really fast. It occurs also if you set that apps in the background should pause.

 

 

Some minor bugs:

The Browser renders a website wrong sometimes if you rotate the device from landscape to portrait mode. But that is not that important for me.

 

 

As for the rest I have to repeat the thread starter: I love the PlayBook as user and developer and I hope we're not at the end because I'm looking forward to what's to come. 

New Contributor
Posts: 6
Registered: ‎02-25-2012
My Device: PlayBook
My Carrier: Vodafone UK

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

[ Edited ]

Quote: " if I type a partial address and notice a match in the drop down for the site I want... I can't click on it, as this triggers the menu's auto-hide action" - steve_web's original post.

 

This is a major flaw and a major annoyance. There have been a couple of OS updates since the comment was posted, but the bug has not been corrected. Surely by now somebody at RIM must have noticed that the URL completion doesn't work. It's not just that the address bar is hidden as soon as you tap one of the dropdown selections, but you lose anything you have written and have to start all over again.

 

Added to that, it's a nightmare trying to edit a URL in the address bar of either the main Browser or the Maxthon mobile browser. Other than deleting everything beyond the part you want to change, there is pretty much nothing that you can do to make the change.

New Member
Posts: 1
Registered: ‎06-26-2012
My Device: Playbook
My Carrier: -

Playbook browser javascript onresize and big picture problem

[ Edited ]

Hi!

I'm just found a bug in the browser and would like to show you. The situation: the browser showed a big image (first image), then I flipped to portrait (second image, the screenshot wasn't successfull, the half of the image was visible normally), then I flipped back to landscape (third image). The half of the image disappeared.



The code was:

<!DOCTYPE html>
<html>
<head>
  
<title></title>
<meta http-equiv="content-type" content="text/html;charset=utf-8" />

  <link href="css/reset.css" rel="stylesheet" type="text/css" media="all" />
  <link href="css/main.css" rel="stylesheet" type="text/css" media="screen" />

  <script src="js/jquery.min.js" type="text/javascript"></script>

</head><body>

<div class="container">  
  <div id="content">
    
    <img id="picture" src="picture.jpg" alt="" />

    <script type="text/javascript">
    
    
    window.onresize = function() {
      alert('ja');
    }
    
    </script>    
  </div>  
</div>  

</body>
</html>


A second thing: the alert doesn't showed up.
If I remove the javascript part, everything seems ok.








Edit: Okay, if I remove the "alert", it seems to work.

Contributor
Posts: 10
Registered: ‎09-28-2012
My Device: 9800
My Carrier: SimFree

Re: Feature Requests/Bug Reports for PlayBook OS 2.0

This is so frustrating! Still wrong now!