Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Highlighted
Trusted Contributor
Posts: 117
Registered: ‎02-05-2009
My Device: BlackBerry Z10

Issue with Contacts - Won't save

I'm having an issue with the Contacts app, and want to see if anyone sees anything similar.


I have facebook, twitter, linkedin, and two gmail accounts. Only one of the gmail accounts syncs my calendar and contacts. I've found that when I try to edit a contact that hasn't properly merged, it won't save.
Example: Let's say I have a contact John Smith. He has facebook, twitter, and I also have him in my Gmail contacts. In Gmail, I have his phone number formated as (212) 555-1212, but facebook pulls it in as +12125551212. So I now have two of the same number for this contact. If I delete the +12125551212 number, it comes right back once it syncs. It will always show both formats of the number, and I can't get it to merge or select a default format for anything. If I try to delete it, it will be gone for a little while. Once it syncs, it's right back.
I've also had an issue with email address types. If John Smiith has johnsmith@home.com and johnsmith@work.com and they are set as personal and work, respectively, it won't save that. It will classify one as personal and the other one as other. Again, it will set it at first. but if the app resyncs while it's open, or if you close it and reopen it and it resyncs, it comes right back.
I had used Gist in the past, and this was one of the thing I really didn't like about it, but there were enough options to be able to work around issues. That isn't the case here, and it seems pretty basic. 
I'm really hesitant to security wipe and start over, as I'm really not having any other major issues. I'd hate to chance causing one over something like this. But with BBX looming on the horizon, I'd like to have my contacts set and ready to go.
Can anyone provide any insight on this, or if you see the same behavior?