Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Member
Posts: 1
Registered: ‎06-16-2012
My Device: playbook 64GB
My Carrier: BT

Re: Play book wont power up or light just blinks

My blackberry Playbook is new, only received yesterday, it wil not switch on for me to even get started, to charge it or anything else. I have tried holding power button down for 10 secs, 20 secs and more. I have tried holding all three buttons down whilst also holding power button for 20 secs, and I have tried just pressing and holding + and power button for 20 seconds = nothing, how on earth am I meant to switch this thing on???

Help please, it was agift and i'm gutted.



New Contributor
Posts: 4
Registered: ‎05-30-2012
My Device: playbook
My Carrier: rogers

Re: Play book wont power up or light just blinks

hey Law, in the sequences you've listed, i didn't see pressing this combo: Power+VolumeUp+VolumeDown only for about 20 seconds (not all of the buttons).  Try the three steps i've listed above and  hopefully you'll have it running soon.  Once it does work it's a really good tablet, especially considering the price.

New Contributor
Posts: 3
Registered: ‎06-21-2012
My Device: 9900; Playbook
My Carrier: Globe

Re: Play book wont power up or light just blinks

Hi Jerry,


 Please help me out here, ive tried everything, holding the power button for at least 30secs, holding the volume keys for at least 30secs as well, tried the desktop update, using mac it says im using the latest update, and ive been browsing all the said tips and tricks how to handle this. my last attempt was to try the stack-charging method. wherein i charged the device for 2mins at a time and then let it sit for 30 secs then plug it again, after my 6th attempt, the red light doesnt show up anymore. and when i plug it to my laptop the red light just pops out for a micro-second then thats it. im clueless as to what i should do next. theres no support here in the manila and i dont know what else i should do. 

Posts: 26
Registered: ‎12-07-2011
My Device: Blackberry Playbook 16Gb
My Carrier: None

Re: Play book wont power up or light just blinks

My PB suddenly wouldn't turn on. I had been using it and charging it ok, for months.


So, just now, I tried fiddling with trying to reset it, using the power and volume buttons. At times, I could see the red light, the green light, the green light flashing about four times, then stopping, and a red battery simbol in the centre of the screen. So, I left it plugged in and, eventually, I got the low battery "door chime". Uh, oh.


When I had turned it off the last time I got to use it, it should have had a good charge in it. This time, it seems the battery had fully discharged. I hope this isn't a sign of further problems because I don't know what would have discharged it. And I'll have to see if a good charging straightens things out, now.


So, my point is, for those who are having trouble turning the unit on, maybe your battery is fully discharged and you need to leave it plugged in for a while. 

Forums Veteran I
Posts: 1,945
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860, Z30
My Carrier: Wind Mobile

Re: Play book wont power up or light just blinks

I do not generally turn off my PlayBook, I just let it go to sleep and about once a week, I do a reboot. Whenever I did tap the stop button, I have had difficulties getting it restarted again and in some cases it would take up to 20 minutes to get it up and running again.
Posts: 1
Registered: ‎06-22-2012
My Device: BlackBerry Playbook
My Carrier: N/A

Re: Play book wont power up or light just blinks

I just had this problem. What finally worked for me was to plug in the PlayBook, hold down the volume up, down, and mute buttons simultaneously. It fired right up and is working fine.  I'm on the OS.

Forums Advisor III
Posts: 1,430
Registered: ‎02-28-2009
My Device: Torch, Bold, Play Book, and Bluetooth HS-700
My Carrier: BELL

Re: Play book wont power up or light just blinks

You did a hard reset. Most of the time a soft reset works well. I tap battery and tap restart. I found sometimes the PB loses its Bluetooth link and resetting is the only fix. I also had instances where it's email client stopped responding properly. 


Jerry G. 


Jerry G.
New Contributor
Posts: 3
Registered: ‎06-22-2012
My Device: Curve 9630 and Playbook
My Carrier: MTS

Re: Play book wont power up or light just blinks

Unfortunately I let my Playbook fully discharge the battery and did not plug it in for about 4 days,  I have read and tried all of the options listed but it has not worked at all. 


The led is not blinking and I have had it on the charge for about 10 hours.  I have also tried plugging into my computer and using the blackberry desktop manager but it does recognize it.


Does anyone have any other options or ideas?  I bought the Playbook at Christmas 2011.  I checked the plugs and connections with my new curve and they all work fine.


Thank you.

New Contributor
Posts: 2
Registered: ‎06-23-2012
My Device: Playbook
My Carrier: Bell

Re: Play book wont power up or light just blinks



I am having the same issue.

My PB's battery was dead for probably over a week.

I plugged it into the wall charger for longer than 10 hours, but I didn't see any lights blinking.


I read this thread, and tried holding the power button for 20 secs, holding power button and the volume buttons for 20 secs, but nothing happened (no red or green light either).


Please tell me how I can start up this one.

By the way, my PB had the new OS.



New Contributor
Posts: 6
Registered: ‎06-23-2012
My Device: Playbook 32 and 64 gig models
My Carrier: MTS

Re: Play book wont power up or light just blinks

Our 32 gig playbook has suffered the same problem....the batery depleted as we where not able to charge at our location....once home tried all the above fixes and it still will not charge, not even a flicker....was on phone with tec support and tried all the fixes again and no go ....anyone have another solution before the unit is discarded....thank you