Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Visitor
Posts: 1
Registered: ‎10-15-2012
My Device: Playbook
My Carrier: BSNL

PlayBook doesn't charge after OS update

I have a serious problem with my BlackBerry PlayBook. It is not getting charged even though I connect it to the power for hours. I believe the problem started after the recent OS update. I tried both USB charging as well as using power cable, but there wasn't any change.

 

I can turn on PlayBook and use it while the power cable is connected. The charging icon is also shown. But it is always showing 0% and the PlayBook get turned off soon after I disconnect power. There isn't any physical damages to PlayBook and power cable. Also it hadn't completely drained out before this problem occurred. After OS update even though I tried charging PlayBook while it has around 20% charge it didn't get charged.

 

 I read some other posts about holding down the power and volume up and down buttons. But it didn't work. Anyone know what might be wrong?

 

Thanks in advance!

Highlighted
New Contributor
Posts: 9
Registered: ‎02-23-2012
My Device: Blackberry Playbook
My Carrier: Rogers

Re: PlayBook doesn't charge after OS update

Same problem here.