Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Posts: 13
Registered: ‎01-17-2012
My Device: Z10
My Carrier: Telus

Playbook Browser Crashes Frequently

This problem occurs frequently, I load a couple pages (always in one tab) usually twitter or other pages such as facebook or google and if i load pages one after another within roughly 30 seconds of each other there is no issue.

As soon as i wait a minute or so and i try to load another page the load bar at the top of the browser below URL box stops at certain spot (always 1/4 of the way there) and stops loading the page and the URL box now becomes empty.

This also happens when i try to open something in a new tab or have been surfing twitter for a while then switch gears to something else i will always get the freeze after a while.

Once i get the freeze i cannot load any other pages and it seems as if the browser crashes (one time it exited on me).

-Wi-Fi is on

-Bluetooth is on and off (tried both ways)

-tried on battery and on power supply

-tried clearing all memory cookies etc

-tried resetting network and wi-fi fixes temporarily but then recurs

-blackberry bridge is off

-file sharing is on

-wifi sharing is on

-tried as single application running and with other applications running as well

-sometimes i get a network error other times i dont


Is there a software application i can get to remedy this really frustrating as i cannot surf now

Any ideas as to the root of the issue?

Any help is greatly appreciated


This playbook is brand new, just bought it barely used  

Trusted Contributor
Posts: 155
Registered: ‎12-26-2011
My Device: PlayBook 16GB + Samsung Galaxy Note
My Carrier: Telus

Re: Playbook Browser Crashes Frequently

[ Edited ]

Try resetting the PB by pressing the Power and both Vol buttons for several secs.
You can also change the WiFi mode to G as some PB works better on G rather than N.
Remove your saved WiFi settings on the PB and try again.

You said it's brand new so have you updated the OS?