Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Member
Posts: 1
Registered: ‎10-14-2013
My Device: Blackberry Playbook 32GB
My Carrier: Cellcom

Playbook Not Charging


I am having problems with a Blackberry Playbook that will not charge or turn on. The red LED light blinks twice and then pauses for about 5 seconds and blinks twice again over and over. I know that in order for the Playbook to charge it needs to be on but I have tried everything to get it to take a charge. Everything includes:

- Putting it on the charger for 2 minutes unplugging it then plugging it in again for 2 minutes and so on for 10 minutes then holding the power button for 30 seconds then plugging it back in for 4-6 hours.

- Holding the power button and unplugging and plugging the charger in 7 times, repeated that 10 times, then allowed to charge 2 1/2 hours

- Hard reset (Power + Volume down + Volume up)

- Charged it from the wall for about 48 hours

- Plugged it into my computer and tried the above again

- Charged it from my computer for about 65 hours

- 3 different power cords that I know work because I charged other playbooks on them the same day

- Checked the prongs on the inside and compared them to other Playbooks and no difference


I have been working on this for a little over a week now and I have Googled it every which way I can think but none of the steps I have come across so far have worked. Is this Playbook savable or is it destined for the technology graveyard? If anyone has any other ideas I can try I would really appreciate it. Thank you.

New Contributor
Posts: 4
Registered: ‎10-21-2013
My Device: 32GB tablet
My Carrier: comcast

Re: Playbook Not Charging

I have exact problem someone help us.

New Member
Posts: 1
Registered: ‎10-24-2013
My Device: Playbook - 16GB
My Carrier: none

Re: Playbook Not Charging

exactly the same with mine


Trusted Contributor
Posts: 156
Registered: ‎11-20-2011
My Device: playbook 16g,32g, 64g (use this every day still), 2-z10's, Passport
My Carrier: Telus

Re: Playbook Not Charging

I'm not sure if this will help you or not but I recently had a friend with the same issue and it was the USB port.  It is very easy to force the wrong way in and damage the opening.  There are 2 ways to charge a playbook.  I used a magnetic charger and it charged up just fine.  I would suggest you borrow one first and see if it will charge before buying one.  They were available through Amazon for about $15.  I paid over 50 for my own. It will also double as a stand for your bedside.  The connection is **bleep** proof too.


Hope this helps