Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
New Member
Posts: 1
Registered: ‎11-17-2012
My Device: Playbook
My Carrier: None

Playbook not switching on

I didn't use my playbook for 3months and now when i tried to switch it on it is not working. I tried to keep it on charging but not working no light nothing. What to do ?
New Contributor
Posts: 2
Registered: ‎11-17-2012
My Device: Blackberry Playbook
My Carrier: MTS

Re: Playbook not switching on

I just posted this about 2 minutes in another thread. Give it a shot, maybe it is the problem you have. 

 

I like many others have been having problems charging my playbook. It was dead, wouldn't turn on, tried everything! From rapid charger to connecting and disconnecting the USB port. I even opened the playbook and disconnected the battery. Finally, something worked. 

 

Solution:

 

I pushed up on the connector with a tiny piece of metal, plastic, (whatever works for you) so the connector that charges the playbook is in the middle. Simply, I reversed the connection, so when I plugged the connector in, it plugged in upside down. I immediately got a charge, the red light came on, from a completely dead playbook and the charging icon flashed. 

 

The problem as I am guessing is that the connector is very flimsy, if you pull the USB cord out of the playbook, it will bend the connector down. By lifting it to about the middle and reversing the connection, it works again. 

 

You can test this simply by observation. On the top piece of the end of the USB, the side which connects to your RIM Blackberry Playbook, you will see two prongs on the outside, clasps. If you look inside the connection of the Playbook, you will see two grooves which these prongs fit into. When you fit the USB into the Playbook, if the prongs on the USB are on the wrong side, you are connecting it upside down. Move the small metal piece in the Playbook up or down to fix.