Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Contributor
Posts: 4
Registered: ‎05-06-2013
My Device: Playbook WIFI
My Carrier: WIFI

Playbook - unable to charge or battery indicator problem??

[ Edited ]
Dear All,
My playbook is unable to charge, the battery is drained to zero.
After carefully reading and understanding http://www.blackberry.com/btsc/KB27705 I bought a rapid charging pod, resulting in the following situation:
latest software is installed 2.0.1xxx
when powering on, red light + 5 times green led flashing
after putting the playbook into the rapid charging pod:
- the red battery symbol appears
- the yellow charging led starts smoothly flashing indicating charging
- after approx 30min or so, the playbook boots up without hitting the power on button
- when finished booting up, the battery symbol is red and completely empty, so I turn off using on screen command "shut down".
- I repeated this process now >5 times, no change in the result
- when waiting until the pb screen is completely turned off (completely dark screen) and hitting the power on button >15-20 sec, the pb is not booting, even no red battery symbol appears
- there is now difference between these procedures when I use the rapid charging pod nor the premium wall charger (with yellow USB plug)
- I also tried to stack charge as seen on youtube- no change
1.) What can I do to make my PB charge?
2.) In case of battery defect, can you please indicate me a playbook repair center in AUSTRIA doing warranty repairs for the playbook?
New Contributor
Posts: 4
Registered: ‎05-06-2013
My Device: Playbook WIFI
My Carrier: WIFI

Re: Playbook - unable to charge

Dear All,


I'd like to share with you some update:


Meanwhile I found out, that the original problem might not be a chargin problem but a battery indicator problem.


I described in the above post, that after connecting to the charger the Playbook is booting up after some minutes without hitting the power on button.


After this boot up, the battery indicator in the top right corner is showing empty battery, red status.


But actually I can continue to use my device for hours without any shutdown of the device!!


Now I am totally confused that moreover after a not measureable time, the battery indicator comes back to show a green battery level. When I put the playbook into the rapid charging pod, it does not show any charging symbol.


Wasn't the battery indicator problem solved in one of the previous OS updates??

My actual version OS