Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Highlighted
New Member
Posts: 4
Registered: ‎01-21-2014
My Device: playbook
My Carrier: EE
Accepted Solution

Playbook will not connect to usb cable

there is something stopping the USB cable from fully engaging in the playbook so it will not charge. Any one know anywhere in the UK to get this repaired, or is this piece of junk really now a piece of junk?

 

MMUK

Guru II
Posts: 22,025
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Playbook will not connect to usb cable

Any cell phone repair facility can probably fix it.

Can you just look in the USB port and see if there is something stuck in there? Maybe a pin is bent?

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Member
Posts: 4
Registered: ‎01-21-2014
My Device: playbook
My Carrier: EE

Re: Playbook will not connect to usb cable

there is nothing obviously wrong - I've had a good look thru a x10 lens. The micro usp will just not go in all the way, and it won't charge. I will try the idea of a repair shop.
Guru II
Posts: 22,025
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Playbook will not connect to usb cable

And you're sure it's not the charger plug itself?

I would purchase one of these:

http://www.amazon.com/Blackberry-Rapid-Charging-Stand-Playbook/dp/B004XDTXZI/ref=sr_1_2?ie=UTF8&qid=...

or one of these:

http://www.amazon.com/Blackberry-Rapid-Travel-Charger-Playbook/dp/B004XBZ728/ref=sr_1_1?ie=UTF8&qid=...

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Member
Posts: 4
Registered: ‎01-21-2014
My Device: playbook
My Carrier: EE

Re: Playbook will not connect to usb cable

I've got several Blackberry (and non BB) usb cables/chargers and they all don't work - same problem, feels like there is something blocking the final mm or so - but i cannot see anything in there
Guru II
Posts: 22,025
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Playbook will not connect to usb cable

If you're concerned mainly about charging then just get a rapid charger or dock. They are far superior anyway and every Playbook owner should have one. Takes all the wear and tear off the USB port.

As for the port itself there's not much we can do here as we can't see in it. You'd have to take to a technician somewhere.

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Member
Posts: 4
Registered: ‎01-21-2014
My Device: playbook
My Carrier: EE

Re: Playbook will not connect to usb cable

thanks for your help. I'll try a repair and a dock!
Guru II
Posts: 22,025
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Playbook will not connect to usb cable

The dock is awesome. I have three Playbook and three docks!

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!