Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

New Contributor
Posts: 3
Registered: ‎04-21-2012
My Device: playbook 64G
My Carrier: Teksavvy

Re: Playbook won't boot after upgrade to v2

Only solution the worked for me was for Blackberry to authorize hardware repair in Tennessee (uner warranty).  Since you have a used model, that may not work. Worth contacting BB to request that.  NO software upgrades from Desktop seemed to work either. However, so software improved the service but not solve completely.  NO one discloses what exact hardware has to be changed.

Posts: 10
Registered: ‎12-31-2013
My Device: Playbook 64
My Carrier: Virgin

Re: Playbook won't boot after upgrade to v2

Blackberry support will not give me any complimentary help and referred me to paid 'incident based support'.  This would almost certainly cost more than the price of a new smartphone or tablet if they recommend returning it for repair so I'm not inclined to go there.


I'm currently exploring other options such as using autoloader to load earlier versions of OS as described on Crackberry site. One thing is not clear yet, do I need to put PB in developer mode before using autoloader?  I obviously can't do that as it is not booting fully yet.  Still, at this point I don't have much to lose so I'll just try it.

Posts: 10
Registered: ‎12-31-2013
My Device: Playbook 64
My Carrier: Virgin

Re: Playbook won't boot after upgrade to v2

I hadn't looked at the playbook since my last post 2 months ago but decided to have one more attempt to salvage it before buying a cheap generic Android tablet.  I'm pleased to say that I now have a working PB again.  I'm adding this post as it may be relevant to others with a similar problem.


The PB had been turned off for nearly 2 months.  I plugged in the rapid travel charger and it displayed the flashing green led indicationg charging, something I had not been able to achieve earlier.  It was left in this state for 48 hours and then switched on.  It was still failing to boot.  I then used the command line utility CFP.EXE with the command "cfp nuke" which clears setup data.  The PB then booted and went through the "as new" setup menus. Part way through the os update process it paused with a message saying there was a low battery and setup would contiue when 20% charge was reached.


  • Back on charge for a further 24 hours - reboot - same problem - waiting for 20% charge.
  • Another 24 hours - no change.
  • It was either not charging or the battery level software was not giving the correct reading - or both.
  • Took off the back cover and checked the battery voltage directly - 3.3volts - so it wasn't charging.
  • Charged directly with my bench power supply current limited to 1.5amps until I got 4.2 volts.- about 90 mins.
  • Re-boot - same problem - waiting for 20% charge - so battery monitor software problem.

At this point I scoured the forums again and came across a post for the same problem where someone had disconnected the battery cable from the pcb (two tiny screws), re-connected and the level had jumped to 100%. They put it down to apoor connection.  I tried the same thing - and it worked!


My conclusions from all this are:

The setup information was corrupted, possible due to battery failure part way through setup.

The PB was unable to boot in this state.

The battery charging software is unable to work from a low charge which is a well documented fault..

The battery charging software has a bug which can prevent it giving the correct battery level after an OS update..


I think disconnecting and re-connecting the battery connector may reset the battery level indicator to read the correct value of 100%. I think this is more likely than a poor connection.


I still think I may have a problem with battery charging and/or level indicating.  It took 12 hours to go from 86% to 87% on the "rapid charger".  I just repeating the exercise with the USB charger.


Hope the above can be of use to someone.  Incidentally,  I find the best way of removing the back cover is to use an old credit card with an edge filed to a wedge profile.




Guru III
Posts: 32,189
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Playbook won't boot after upgrade to v2

I have seen the romavale of battery connector and re connect fix a few PlayBooks.


Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

Posts: 10
Registered: ‎12-31-2013
My Device: Playbook 64
My Carrier: Virgin

Re: Playbook won't boot after upgrade to v2

Further to earlier post, the battery has gone from 87% to 88% in 6 hours on the USB charger so this is something like 4 times faster than the "rapid charger".