Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Visitor
Posts: 1
Registered: ‎10-11-2012
My Device: playbook 64GB
My Carrier: ATT

won't charge and there is no red light

[ Edited ]

All,

 

I know this won't-charge thing has been repeated asked and answered but I don't see my specific situation mentioned before.

 

My 64GB playbook was bought last yr and worked smoothly till last week then battery suddently dropped to 10%. After a few reboot, it dropped again to 0%. And when I pressed the power button, the red light did flash.

 

So I hooked up with the default wall charger for 1 day. no charge. and the red light was GONE as well.

 

Now the PB is completely dead. When I plug in the wall charger, NOTHING happens. NO red light.

 

So I bought an official rapid charger from Amazon, hooked up for 1 day. nothing happens.

 

Press power button + Volume Up/Down for 20 sec, nothing happened.

 

The only thing I haven't tried is to hook up with laptop using the USB cable. I lost mine a while back and just ordered one from Amazon.

 

Anyone had similar problem?

 

LH

Highlighted
Super Contributor
Posts: 367
Registered: ‎09-22-2012
My Device: Playbook 32
My Carrier: 3

Re: won't charge and there is no red light

If it's out of guarantee try the battery clip reconnect here. http://supportforums.blackberry.com/t5/BlackBerry-PlayBook/PlayBook-Turn-on-but-won-t-charge/m-p/192...

________