Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Posts: 1
Registered: ‎10-11-2012
My Device: playbook 64GB
My Carrier: ATT

won't charge and there is no red light

[ Edited ]



I know this won't-charge thing has been repeated asked and answered but I don't see my specific situation mentioned before.


My 64GB playbook was bought last yr and worked smoothly till last week then battery suddently dropped to 10%. After a few reboot, it dropped again to 0%. And when I pressed the power button, the red light did flash.


So I hooked up with the default wall charger for 1 day. no charge. and the red light was GONE as well.


Now the PB is completely dead. When I plug in the wall charger, NOTHING happens. NO red light.


So I bought an official rapid charger from Amazon, hooked up for 1 day. nothing happens.


Press power button + Volume Up/Down for 20 sec, nothing happened.


The only thing I haven't tried is to hook up with laptop using the USB cable. I lost mine a while back and just ordered one from Amazon.


Anyone had similar problem?



Super Contributor
Posts: 367
Registered: ‎09-22-2012
My Device: Playbook 32
My Carrier: 3

Re: won't charge and there is no red light

If it's out of guarantee try the battery clip reconnect here. http://supportforums.blackberry.com/t5/BlackBerry-PlayBook/PlayBook-Turn-on-but-won-t-charge/m-p/192...