Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Contributor
Posts: 14
Registered: ‎04-23-2012
My Device: Bold
My Carrier: 2063103963

PAP push not being received on device

Hello all;

 

I am trying to implement push to my app running on BB7.x via BES 4.x.  To start out, I used the HTTPPushDemo application on my device and removed the check for whether its running on a simulator - I'm running on a real device - and listening on port 100 as per the standard demo code.  Then, I followed the instructions for the server-side code to make a PAP or RIMPush connection to MDS and push the data through.  When I do my PAP push (the RIM push always fails with an error 400 but I'm not too concerned about that right now), I receive a 202 status code from MDS but my app (HTTPPushDemo)  on the device never receives the push notification.

 

I've gone into the MDS configuration on my BES system and made sure that port 100 is in the list of device ports (it was previous just set to 7874).  But still, no notification on my device.

 

Can anyone think of what I may be missing here?  Any help will be greatly appreciated.

 

Thanks much

 

ShaunB...

Highlighted
Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: PAP push not being received on device

Make sure to browse the Internet using the Browser before sending the Push. This is required once before Pushes will arrive when using BES versions less than 5.0.

Garett
@garettBeuk
--
Goodbye everybody!