Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
New Contributor
Posts: 4
Registered: ‎02-26-2013
My Device: we are developper
My Carrier: we are developper

PUSH service not working

Hi all,

we are developer of SKEBBY (http://freesms.skebby.com/) a famous blackberry application for free SMS. Starting from 6 February we are encountering problem with your RIM PUSH SERVICES, we wrote a couple of email to support and finally to BlackBerryPushServices@rim.com where they suggested me to post a message here, there is anyone who can help us sorting it out. Our application is not working as we wished and some user are complaining about us and Blackberry.

 

Retired
Posts: 76
Registered: ‎08-08-2012
My Device: BlackBerry Z10
My Carrier: Rogers

Re: PUSH service not working

Could you provide more details? What exactly is not working - are you getting an error somewhere that we can investigate further?

New Contributor
Posts: 4
Registered: ‎02-26-2013
My Device: we are developper
My Carrier: we are developper

Re: PUSH service not working

[ Edited ]

sorry for the delay of our answer, my techician told me that:


when we try to do the POST to

https://cpxxx.pushapi.na.blackberry.com/mss/PD_pushRequest
to the port 20558

with application ID <removed>

we receive a 403 error

some months ago all was fine and then suddenly it stop to work

 

Do you made same change or can we do something to reactivate it.

 

we thank you in advance and stay at your disposal.

Retired
Posts: 76
Registered: ‎08-08-2012
My Device: BlackBerry Z10
My Carrier: Rogers

Re: PUSH service not working

No changes were made.

 

The port number is only required by your device side application on BlackBerry OS <=7. BlackBerry 10 device side applications no longer require the port. And port was never required when initiating a push from your server side application. 

 

So ensure you are not POSTing your request to the port from your server side application. Also ensure you are setting the Basic Auth header when you initiate the push in the form of <Application-Id>:<password> and base64 encoded 

New Contributor
Posts: 4
Registered: ‎02-26-2013
My Device: we are developper
My Carrier: we are developper

Re: PUSH service not working

No change were made also on our side, so we do not understand why it suddently stopped, it could be possibile that we missed some sort of payment or activation cost to blackberry ? If it was so how much would it cost to have BIS (blackberry internet services) reactivated ? There would be any alternative to let us interact with the mobile phone of our client ?

 

many thanks

 

 

Retired
Posts: 76
Registered: ‎08-08-2012
My Device: BlackBerry Z10
My Carrier: Rogers

Re: PUSH service not working

[ Edited ]

 If your application had expired or was inactive you would receive a 401 error (not a 403) error. I tried pushing to your URL using my own app id: https://cpxxx.pushapi.na.blackberry.com/mss/PD_pushRequest and it worked so the URL is certainly correct.

 

Are you sure nothing changed on your end, for example, firewall or other networking changes that may be blocking this outgoing request now?

 

New Contributor
Posts: 4
Registered: ‎02-26-2013
My Device: we are developper
My Carrier: we are developper

Re: PUSH service not working

Hi,

we didn't change anything, Bis suddendly stop to run without any alert and never restarted, do you have any suggest about how to sort it out and reactivate this service ?

 

Retired
Posts: 311
Registered: ‎08-08-2012
My Device: BlackBerry Z10
My Carrier: Rogers

Re: PUSH service not working

Please try to avoid posting your application ID to to forums as well as your content provider ID.

 

What is the exact error description that you get back with the 403 error?

 

Also, you mentioned port 20558.  What is this exactly?  When you send a push out, you do not specify a port.

 

Thanks,

 

Matt