Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Contributor
Posts: 30
Registered: ‎09-01-2013
My Device: Q5
My Carrier: Orange

SubscriptionContentNotAvailable - 10110 - Working yesterday?!

Hi,


I am this morning getting an SubscriptionContentNotAvailable 10110 error. It was working last night, nothing has changed since.

 

Thanks!

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

Did you re-install the app or make any code changes at all to the app? Do you have any other apps on the device using the same push credentials?

Are you testing using WiFi or cell network?

 

As an aside: the channel should only need to be created once, possibly once every 60 days to be safe, but not every day.

Garett
@garettBeuk
--
Goodbye everybody!
Contributor
Posts: 30
Registered: ‎09-01-2013
My Device: Q5
My Carrier: Orange

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

[ Edited ]

I've just done a security wipe, that hasn't fixed it.

 

I changed no code, worked last night,can't get it working today :/

 

Also this is the code I'm using;

 

	initializePushSession();

	//See if we have a a push channel already if not, create one.
	pushCreated = getPushChannelCreated();
	if(!pushCreated){
		qDebug() << "Push NOT Created";
		createChannel();
	} else {
		qDebug() << "Push created";
		loggedIn = getLoggedIn();
		if(!loggedIn){
			showLoginPrompt();
			changeConnectionText("Connection Status: Not logged in.");
			qDebug() << "not logged in";
		} else {
			changeConnectionText("Connection Status: Logged in!");
			qDebug() << "logged in";
		}
	}

 

Console log:

msg::onCreateChannelComplete
id::createChannel_30039
err:n:10110
err is  10110 
No dat section 
creatChannelComplete status:  10110 
createChannelComplete token:  "" 
PpsObject::decodeValue: Failed to decode type:  PPS_TYPE_DELETED for data 
PpsFile::read: deserialize ERROR:  "/pps/services/pim/status?wait,delta" : "@status

 

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

Does the session get created successfully? And are you testing over WiFi or Cellular networks?

Garett
@garettBeuk
--
Goodbye everybody!
Contributor
Posts: 30
Registered: ‎09-01-2013
My Device: Q5
My Carrier: Orange

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

[ Edited ]

Yes it is;

 

msg::onCreateSessionComplete
id::createSession_30039
err is  0 

 I have two devices, I've tried over ceullar and WiFI

New Developer
Posts: 13
Registered: ‎09-12-2013
My Device: Z10
My Carrier: BG Globul

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

I have the same problem since yesterday

Contributor
Posts: 30
Registered: ‎09-01-2013
My Device: Q5
My Carrier: Orange

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

Still the same issue this morning. This must be a server side issue?

Highlighted
Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

I'm getting some strange errors reported from other sources about EVAL having issues. I'm investigating and will let you know what I hear back.

Garett
@garettBeuk
--
Goodbye everybody!
Developer
Posts: 148
Registered: ‎04-08-2013
My Device: Blackberry 10
My Carrier: Blackberry

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

Iam also getting the same error.Any one got some solution.Is that a server side error??AnyOne PLz reply

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: SubscriptionContentNotAvailable - 10110 - Working yesterday?!

Is anyone on this thread using PRODUCTION credentials?

Garett
@garettBeuk
--
Goodbye everybody!