Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Visitor
Posts: 1
Registered: ‎01-11-2011
My Device: Not Specified

Test Push Service not working in China (China Mobile)

I am trying to test the Push Service via China Mobile in Shanghai. When registrering to 

http://pushapi.eval.blackberry.com I get a message with the demo app that 

 

"scheduled registration with BPAS" and nothing happens. Testing the same app in Germany everything works. I already googled a bit and it seems that the push service via BIS is not available in china.

Does anybody have any experience with push service in China?

Kind regards,

János

New Member
Posts: 1
Registered: ‎01-11-2011
My Device: Curve 9300 OS 6.0
My Carrier: Wind

Re: Test Push Service not working in China (China Mobile)

I had a Curve 9300 from Wind which I unlocked and is using the China Mobile service wthout any problem. I purchased a local SIM card and never experience any problem with my push mails. It worked fine.Smiley Happy

New Contributor
Posts: 8
Registered: ‎04-27-2010
My Device: BlackBerry 9780
My Carrier: China Mobile

Re: Test Push Service not working in China (China Mobile)

Hi I was testing something like this too. However, there is some info. Since mid November 2010, China Mobile was opening BIS for CMCC's subscribers. If you had a ShangHai CMCC sim card, you should be able to send a text message "KTBIS" to 10086 to open BIS. That will cost 98RMB per month, 30MB or 50MB traffic depends on local price tag. Currently I can get a successful BPAS registration but can't receive my custom push from server. Wondering which was going wrong, the same code had worked several months ago with my friends PIN in USA.
Contributor
Posts: 10
Registered: ‎11-11-2009
My Device: 9650 Bold
My Carrier: Sprint

Re: Test Push Service not working in China (China Mobile)

I hope this is a good thread to use.  I'm a pilot & get to China about 3 times a month for a whole 45 hours each time. I used to have a GSM NOKIA phone with a local sim card and my Sprint BB with CDMA.  My web and emails worked fine on my sprint but pricy so did not use much.  My NOKIA wasn't web capable so I never had data on my sim card. Last year I bought a Sprint 9650 BB.(CDMA & GSM) and it is great to have all my contacts in one place.  I added a small data package to my SHangHai SIM card but it will not work.  Spent some time at the China Mobile Store on this layover and a couple of guys were helping out as best they could. (Language issues).

 Here;s what we found out::

If i take my sim card and put it into one of their phones then it works fine. I had tried this earlier with a colleague's phone.  That that tells me the sim card is OK.  Now we trid to figure out what was happening with my 9650.  We compared the settings in one of their BB's to mine.  It seems I am missing some Service books, so they tell me.

 

Here are some other things i've noticed:

   When I boot up with the SIM card I only have the WiFI browser, no internet browser.

   I can trick the phone and boot up in CDMA and then switch to GSM. Now I have the Internet & web browsers but if I try to do any data tasks it says "insufficient network coverage..."

  I used to have an icon with some chinese stuff associated with it but it was sporatic and I can't figure how to get it back.  It may have been part of a setup.

 

  The China Mobile reps Googled their hearts out and found a website and suggested I download a file which is suppose to have the Service Books.  It is "ServiceBook_Net_Wap_Email.ipd".  What do I do with that?

Any suggestions? It's a bummer that I can make changes at home but can't check again until I get back to china.

I will bring an old unlocked AT&T BB on my next trip to see what happens with my sim card in it..

Got to head to airport and back to SFO.

xie xie in advance.

George 747

 

Contributor
Posts: 10
Registered: ‎11-11-2009
My Device: 9650 Bold
My Carrier: Sprint

Re: Test Push Service not working in China (China Mobile)

I tried this a minute ago.  Got  a text back but totally in chinese.  it lookes like i have options 1-9 to choose from. Hmmm?  I wonder what's behind option 8?  I suspect it would be a lucky choice.  It will have to wait until next trip back to China to decipher.   Off to the airport soon. 

George 747