Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Q10

Reply
New Member
Posts: 4
Registered: ‎07-31-2014
My Device: Z30
My Carrier: vipnet

Q10 working only on EDGE

I purchased Q10 in Italy last year. Since the day one it was not working while connected on 3G or 4G. But everything is fine while on EDGE signal.

 

I paid 700.00 EUR for device and now had to purchase new device (Z30) because no one in Croatia wouldn't accept international warranty from BlackBerry, since it hasn't been purchased in Croatia.

 

Have been loyally to the Company for the last 5 year (this is now my 6th BlackBerry device) but this has really made me disappointed. I am stuck with malfunctioning Q10 after expense of 700.00 EUR

Developer
Posts: 1,269
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Q10 working only on EDGE

Did you purchase the device from a carrier who claimed it worked on your 3G/4G network?

 

If not, did you purchase an unlocked device version with the correct radio bands for your carrier?

 

See for example these specs for device model variants and the bands supported by each one:

 

http://www.gsmarena.com/blackberry_q10-5274.php

New Member
Posts: 4
Registered: ‎07-31-2014
My Device: Z30
My Carrier: vipnet

Re: Q10 working only on EDGE

Thanks for your help. Yes the phone is proper one for my country (the same model of frequency us being sold here). Unfortunately I have tried everything; testing the number, swapped the SIM, changed network operator, they (network) tested their signal antennas, etc.

Nothing helped.

 

The phone starts to work on 3G or 4G mode and then suddenly stops. The problem is that you cannot know that unless you are working at the moment because the signal strength is normally showed as full, but no data, no receiving or making a phone calls because it says call error calling, impossible to make call (or something like that). Then it shows red x for the signal and searching network.

 

When I called Croatia service they said is problem with 3G and 4G module antenna but wouldn't accept the phone.

 

Hopefully BlackBerry can do something about it.

 

 

Developer
Posts: 1,269
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Q10 working only on EDGE

Are you sure that the carrier will allow a phone purchased somewhere else to be on their network?  In some countries, for example Turkey, phones brought in from outside the country have to be registered with the authorities before the carrier will allow them to be on their networks.  For example if you put a local SIM card from a Turkish carrier into your unlocked phone brought in from outside the country, it will stop working after a few days to weeks and you will have to go register it with the government if I recall correctly.

Highlighted
New Member
Posts: 4
Registered: ‎07-31-2014
My Device: Z30
My Carrier: vipnet

Re: Q10 working only on EDGE

Yes, I talked to them many times regarding the given situation.

Also, I purchased my new Z30 abroad, as well and it works marvellous. So... it is faulty Q10.

 

Thanks for your info about Turkish situation.