Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Q5

Reply
Visitor
Posts: 1
Registered: ‎08-27-2013
My Device: Q5
My Carrier: Q5

Keys on keyboard not working **not water damage**

The Alt, X, V, B, and $ keys are not working on my Q5. Got it as a present and only started using it a few days ago. I did not get it wet or drop it. I live in Canada and my friend bought for me from the UK. I was told that the warranty will not apply in Canada if I bought the phone in the UK. That is absolutely ridiculous. 

Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Keys on keyboard not working **not water damage**

Unfortunately that's the risk you take when importing from another country.

 

The options are to either send it back to your friend to get a replacement or use a repairer in your own country.

 

If you are competent taking electronic equipment apart it's fairly simple to replace the keyboard but of course no guarantee that it will fix the problem.

 


If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
New Member
Posts: 3
Registered: ‎11-11-2013
My Device: Blackberry Q10
My Carrier: Rogers

Re: Keys on keyboard not working **not water damage**

I have the exact same problem with the EXACT same keys. Rebooting only solves the issue for a couple of hours before I have to reboot again! Very suspicious that it is only the alt, x, v, b, and $ keys as well.
New Contributor
Posts: 2
Registered: ‎06-07-2014
My Device: q5
My Carrier: q5

Re: Keys on keyboard not working **not water damage**

I have exactly the same problem with my Q5 : it appeared after an update of the OS 10.2.1. When I reboot with factory settings the keyboard is OK but after OS loading these special keys alt x v b $ just stop working. In another forum, someone say that the UI or keyboard driver is corrupted but I don't know to have the correct driver. So I ask the help of the communauty : it is very frustrating that this "old" problem isn't solved on my new phone (bought in May). Thanks

New Member
Posts: 3
Registered: ‎11-11-2013
My Device: Blackberry Q10
My Carrier: Rogers

Re: Keys on keyboard not working **not water damage**

I eventually brought my phone back to the carrier and they sent it away to get it fixed. Haven't had issues with the keyboard since.

New Member
Posts: 1
Registered: ‎01-25-2015
My Device: Blackberry Q5
My Carrier: Etisalat

Re: Keys on keyboard not working **not water damage**

I have the similar problem with different keys. Rebooting only solves the issue for a couple of hours before I have to reboot again! Very painful that it is only the a, z, q and spacebar keys.
New Contributor
Posts: 2
Registered: ‎06-07-2014
My Device: q5
My Carrier: q5

Re: Keys on keyboard not working **not water damage**

During 4 months, i could solve the problem when it appeared by changing the country zone in parameters and rebooting. But with the new OS version the same default country zone appeared after rebooting. So i turned back my Q5 and they changed it.

New Member
Posts: 1
Registered: ‎03-02-2015
My Device: Q5
My Carrier: T-Mobile

Re: Keys on keyboard not working **not water damage**

Yep, EXACT SAME problem here. I might try an OS upgrade, really hope it's just a driver glitch and not something in the hardware...
New Member
Posts: 1
Registered: ‎04-14-2015
My Device: q%
My Carrier: Claro

Re: Keys on keyboard not working **not water damage**

Same problem here... Smiley Sad the reboot only solves the issue for a short period of time!!

I have factory reset the device and now upgraded to the lastest os (10.3)

 

The defected keys I have are ERSDXP.

 

Any ideas?

New Member
Posts: 1
Registered: ‎07-06-2015
My Device: Q5 - SQR100-2
My Carrier: Play

Re: Keys on keyboard not working **not water damage**

I have exactly the same problem with my phone. Latest OS, but no help at all. I'll actually try to downgrade the OS to see what happen. First I thought its software problem - because restart helped for some time, but now I'm not sure, because it doesn't help any more.