Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Web Services

Reply
fgb
New Contributor
Posts: 8
Registered: ‎03-16-2011
My Device: none
My Carrier: none

API v5.0.2.25 and API v5.0.0.26 compatibility

Developing a java based component for provisioning users with BES 5.0, we are using the Blackberry Administration API. The version we are using is the one coming with the BES installation we downloaded, v5.0.2.25.

 

Is there any problem using our component that we developed with this version of the API against a customer installation of BES 5.0.0.137, when they download and install the 5.0.0.26 version of the Administration API's ?

 

We need to know if the differences/changes are such between the two versions that some parts won't work. Maybe it is just about a few enhancements but we need to make sure.

 

Thanks,

Highlighted
Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: API v5.0.2.25 and API v5.0.0.26 compatibility

The BlackBerry Administration APIs are forwards compatible, not backwards. So an application developed for BAA 5.0.0 would work in 5.0.2, but one developed for 5.0.2 would not work in 5.0.0. Generating a proxy against the 5.0.0 BES and replacing the 5.0.2 proxy in your application would verify this (show errors) and also let you know what changes have been made between the versions.

 

Regards, 

Garett
@garettBeuk
--
Goodbye everybody!