Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Web Services

Reply
New Member
Posts: 3
Registered: ‎02-13-2013
My Device: BB10
My Carrier: Roger
Accepted Solution

BES10 - BDS WipeDeviceRequest organizationWipeOnly = true does not work

I have an issue when trying to perform Work space only wipe through BES10-BDS BWS api. Here is the call, please let me know if there are things seem out of place, thanks in advance. OffboardingType type = new OffboardingType(); type.DELETE = true; SetDevicesWipeRequest wipeReq = new SetDevicesWipeRequest(); wipeReq.metadata = WSMetaDataWS; wipeReq.devices = new Device[] { device }; wipeReq.offboardingType = type; wipeReq.organizationWipeOnly = true; SetDevicesWipeResponse wipeRes = BwsService.setDevicesWipe(wipeReq);
Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: BES10 - BDS WipeDeviceRequest organizationWipeOnly = true does not work

What's the issue you're having?

Can you wipe successfully from the BAS with the same user account?

Garett
@garettBeuk
--
Goodbye everybody!
New Member
Posts: 3
Registered: ‎02-13-2013
My Device: BB10
My Carrier: Roger

Re: BES10 - BDS WipeDeviceRequest organizationWipeOnly = true does not work

[ Edited ]

Via API call it just does not perform the operation, the call pass through with success status, but does nothing.

 

Via BAS with the same user account does work with wipeing work data only

 

Via API call to do full device wipe works as well.

 

Thanks for the help

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: BES10 - BDS WipeDeviceRequest organizationWipeOnly = true does not work

Thanks for confirming.

 

Could you post the full method code? Please use the code block so the formatting stays legible.

Please also post the response received back after executing this call.

Garett
@garettBeuk
--
Goodbye everybody!
Highlighted
New Member
Posts: 3
Registered: ‎02-13-2013
My Device: BB10
My Carrier: Roger

Re: BES10 - BDS WipeDeviceRequest organizationWipeOnly = true does not work

Hi Garett,

 

I have found the issue, it is because the ForceDeleteDevice flag is also set to true, which the ForceDeleteDevice take precedence and remove the device out of the user hence the wip does not work.

 

Thanks for the help though.