Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Posts: 27
Registered: ‎02-04-2011
My Device: Not Specified

App world minimum OS -- how does it work?



We're going to be releasing a new version of our app, and it's got a bit of a tricky versioning scheme:


For devices running 4.6, we want to provide Build #1

For devices running 4.7, we want to provide Build #2

For devices running 5.0 or above, we want to provide Build #3


When we specify minimum OS in the app world, is it possible to do this? If we specify one bundle as having a minimum OS of 4.6, and another with minimum OS of 5.0, will users on OS 6 get the one requiring a minimum of OS 5 ?


The reason this is so complicated is that we've had issues in the past with touch-compatibility mode being triggered when loading an app built with JDE 4.6 on devices running 4.7, and in addition, we have a build of our app which integrates Facebook using the recent release of the Facebook SDK from RIM, and that requires OS 5.