Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Visitor
Posts: 1
Registered: ‎02-21-2012
My Device: 9650
My Carrier: TrueMove

Dynamic Licensing, got PIN 0 from RIM server

[ Edited ]

My app (tinycontroller) uses Dynamic Licensing. It works fine. But sometimes, i got a request with PIN=0 and empty email address. Until now it just happens very infrequently (once every one or two weeks) and I never really care about it. I have verified that everything works fine in my side, and sales works fine. I have also verified that the request came from RIM IP Address (I have compared it with the usual sales log).

 

But in the past hour, I got 14 of this kind of request (PIN=0, email is empty, from RIM IP Address), and no valid purchase today. Is this normal? Anyone experienced this?

 

Update: 1 hour after i posted this, I got another 7 messages (all with PIN=0, empty email), example request from RIM (all requests came from RIM IP: 208.65.78.13):

 

product=TinyController&email=&test=false^transactionid=158XXXX&PIN=0&sku=tinycontroller &version=1.2.2.0&metadata=

 

Transaction id seems to be valid (increasing).

 

I've also tried to buy my own app, and it works fine, the request is as it should be. But I kept  getting this strange requests.

 

 

Developer
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: Dynamic Licensing, got PIN 0 from RIM server

Same here.
New Developer
Posts: 29
Registered: ‎09-25-2010
My Device: Not Specified

Re: Dynamic Licensing, got PIN 0 from RIM server

I've noticed this as well. Guys what the the heck is this???

Developer
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: Dynamic Licensing, got PIN 0 from RIM server

This does not seem to be getting better. We are getting a lot of these.

 

Users are not going to be happy if these are legitimate license requests.

 

Who else is seeing this?

Developer
Posts: 1,452
Registered: ‎11-06-2009
My Device: Torch 9810
My Carrier: WiFi

Re: Dynamic Licensing, got PIN 0 from RIM server

Hm, any chance that this is an upgrade request?



"When you become a level 3 developer, you learn to communicate over the ether. I'm told that level 5 developers are ascend into a higher level of existence beyond the physical realm." gord888 @ crackberry
Developer
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: Dynamic Licensing, got PIN 0 from RIM server


QuiteSimple wrote:

Hm, any chance that this is an upgrade request?


I don't know.  It's very unsual - no email addy and PIN is zero.

 

My best guess is the server is sending a request when the user downloads a trial version.

 

We've got well over 100 of these requests since yesterday.

Trusted Contributor
Posts: 224
Registered: ‎08-11-2010
My Device: Not Specified

Re: Dynamic Licensing, got PIN 0 from RIM server

Just fyi, we observe similar problems (very high number in invalid HTTP POST requests during last 48 hours), I have created a separate forum thread. 

 

We have observed & reported similar problems in the past (last time - on October 19, 2011), but we never got a resolution from RIM.

 

What we are really worried are the HTTP POSTs with missing PIN, but with new transactionid ... we are worried that some people that purchased an app won't be able to activate it. 

 

Good luck,  

 

 

 

Developer
Posts: 1,452
Registered: ‎11-06-2009
My Device: Torch 9810
My Carrier: WiFi

Re: Dynamic Licensing, got PIN 0 from RIM server

Here is the official response (although in another thread)

http://supportforums.blackberry.com/t5/BlackBerry-App-World-Development/URGENT-many-bad-HTTP-POST-re...



"When you become a level 3 developer, you learn to communicate over the ether. I'm told that level 5 developers are ascend into a higher level of existence beyond the physical realm." gord888 @ crackberry
Highlighted
Regular Contributor
Posts: 52
Registered: ‎07-28-2011
My Device: Blackberry Torch 9800
My Carrier: T-Mobile

Re: Dynamic Licensing, got PIN 0 from RIM server


tinycontroller wrote:

My app (tinycontroller) uses Dynamic Licensing. It works fine. But sometimes, i got a request with PIN=0 and empty email address. Until now it just happens very infrequently (once every one or two weeks) and I never really care about it. I have verified that everything works fine in my side, and sales works fine. I have also verified that the request came from RIM IP Address (I have compared it with the usual sales log).

 

But in the past hour, I got 14 of this kind of request (PIN=0, email is empty, from RIM IP Address), and no valid purchase today. Is this normal? Anyone experienced this?

 

Update: 1 hour after i posted this, I got another 7 messages (all with PIN=0, empty email), example request from RIM (all requests came from RIM IP: 208.65.78.13):

 

product=TinyController&email=&test=false^transactionid=158XXXX&PIN=0&sku=tinycontroller &version=1.2.2.0&metadata=

 

Transaction id seems to be valid (increasing).

 

I've also tried to buy my own app, and it works fine, the request is as it should be. But I kept  getting this strange requests.

 

 


Hi All,

 

I also use Dynamic Licensing and am also encountering these exact same issues, I have contacted RIM support 3 times already and was told 2 weeks ago that it will be resolved in a few days, we are now into the third week and some of my transactions are still appearing with no email address and 0 as Blackberry PIN.

 

These records are also not showing up as purchases within App World reports but shows up as being valid license requests from my dynamic licensing system, so I am just a little weary if this will be credited or not.. (I have been reassured from Blackberry help that it will be) although I am not too confident

 

If this issue has been ongoing for around 4 weeks already, why has this not been escalated/resolved?

 

Are some of you guys still experiencing the same issues? The other thread containing the link does not have information if this has been solved.

 

Please advise thanks

Developer
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: Dynamic Licensing, got PIN 0 from RIM server

Yes, it's still a problem.